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Introduzione al Sistema Operativo INFO-OS 
INFO-OS è un Sistema Operativo Embedded Storage definito dal software, che incorpora 
tecnologie di rilevamento della corruzione dei dati e self-healing, inoltre integra 
tecnologie di backup e replica automatici.  
 
Utilizzando la tecnologia dei sistemi INFO-OS è possibile gestire policy di accesso 
dirette ai dati o tramite la semplice integrazione con Microsoft Active Directory.  
INFO-OS vanta inoltre una serie di funzioni avanzate quali: file system ZFS, RAIDZ, 
Copy-On-Write, snapshot(backup) istantanei, replica (a)sincrona, backup remoti e 
incrementali automatizzati. 
 
I sistemi Converged e Storage INFO-OS sono in grado di proteggere le VM e i dati 
attraverso un numero potenzialmente illimitato di copie di snapshot, con la possibilità di 
replica locale o remota.  
In questo modo, i sistemi potranno essere sempre immediatamente ripristinati in tempi 
praticamente istantanei. Errori del software, errori degli utenti e altre problematiche 
come attacchi informatici non saranno più un problema. 
La piattaforma INFO-OS integra tutte queste soluzioni in un unico sistema, semplice da 
configurare e facile da usare. 
 
Questa guida utente riporta le informazioni utili all’utilizzo, configurazione e 
manutenzione del sistema INFO-OS.  
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Installazione di INFO-OS 
Una volta eseguito il BOOT dal file .ISO o chiavetta USB di installazione di INFO-OS si 
presenterà la seguente schermata, qui sarà necessario premere “7” per eseguire il 
Wizard di installazione: 
 

 
 
Una volta avviato il Wizard verrà richiesto quale tipo di installazione eseguire: 

1.​ Installazione/upgrade ‘Embedded’ 
2.​ Installazione/upgrade ‘Full’ 
3.​ Conversione di installazione da ‘Full’ a ‘Embedded’ 
4.​ Opzioni avanzate 

Un sistema installato Full legge e scrive sul dispositivo fisico su cui è installato durante 
l’operatività del sistema, mentre un'installazione Embedded decomprime il S.O. nella 
RAM e lo esegue da lì, assicurando l’integrità dei file scritti sul disco fisico prevenendo 
buona parte dei possibili eventi disastrosi. 
Nella maggior parte delle configurazioni il sistema viene installato in modalità 
‘Embedded’, pertanto selezioniamo l’opzione “1” (già preselezionata) e premiamo invio 
sull’OK: 
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Alla successiva schermata verrà richiesto come effettuare l’installazione, se in GPT, 
UEFI o MBR e se utilizzare o no una partizione SWAP per i dati.  
Generalmente si installa in modalità GPT poiché equivale a Legacy. Se dovesse essere 
impossibile l’installazione Legacy, si procede in EFI per UEFI. In entrambi i casi con la 
SWAP attiva, pertanto selezioniamo la prima opzione “1” o “2” e ri-confermiamo al 
riepilogo che si presenta successivamente: 
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Ora verrà richiesto quale disco contiene i file di installazione, selezioniamo la .ISO o 
l’USB e andando avanti verrà richiesto il disco nella quale installare il sistema operativo: 
 

 

 
 
Infine verranno richieste le dimensioni delle partizioni da creare, è best practice 
configurarle come segue: 

1.​ Size of the OS partition (Dimensione della partizione del S.O.) = 4G​
Che sta a significare che tale partizione sarà da 4 GB. 

2.​ Size of the SWAP partition (Dimension della partizione SWAP) = 16G​
Che sta a significare che tale partizione sarà da 16 GB. 

3.​ Size of the DATA partition (Dimensione della partizione DATA) = ALL​
Che sta a significare che tale partizione sarà equivalente allo spazio restante sul 
disco in questione. 
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A questo punto l’installazione inizierà e quando completata mostrerà l’esito con la 
dicitura: “Info-OS has been installed on [...]”. 
 
Qui si potrà, come suggerito a video, premere INVIO per continuare e si verrà riportati 
alla prima schermata del Wizard di installazione dove potremo selezionare Exit per 
uscire ed eseguire lo spegnimento/riavvio (6 o 5) per rimuovere a sistema spento la .ISO 
o chiavetta USB di Installazione: 
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Accesso alla Web Interface 
In fase di prima installazione della macchina sarà necessario visualizzare la console a 
video per identificare e/o modificare l’indirizzo IP di accesso alla Web Interface (di 
default impostato in DHCP - vedi: Configurazione interfacce tramite console per ulteriori 
informazioni). ​
 
Si potrà eseguire il login alla stessa tramite browser (Mozilla Firefox) con le seguenti 
credenziali: 

●​ Utente: ​ useradmin 
●​ Password:​ admin 

 
Di seguito la schermata principale alla quale si accede una volta eseguito il login alla 
Web Interface: 
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Backup della configurazione 
Per eseguire un backup della configurazione (si tratta della configurazione del S.O. e 
non ha nulla a che vedere con i dati del pool): 

●​ System → Backup → [Download Configuration] 
 

 

Restore della configurazione 
Per eseguire il restore della configurazione è sufficiente caricare il file .xml, scaricato in 
precedenza quando si è fatto il backup, nella seguente pagina: 

●​ System → Restore → [Restore Configuration] 
 

N.B.: In seguito al Restore della configurazione INFO-OS si riavvierà in automatico. 
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Aggiornare INFO-OS 
Per eseguire un aggiornamento di sistema è necessario programmare un fermo 
macchina, poiché ogni aggiornamento comporta il riavvio automatico di INFO-OS. 
Prima di eseguire l’aggiornamento è necessario eseguire il backup della configurazione 
e assicurarsi di non aggiornare mentre si stanno eseguendo operazioni come Snapshot 
schedulati o Repliche. 
 
Per scaricare il file di aggiornamento: 

●​ System → Firmware → Download 
Per eseguire l’aggiornamento, nella stessa pagina: 

●​ Enable Firmware Upgrade → Sfoglia [file] → Upgrade Firmware 
 
N.B.: A partire dalla versione 4 di INFO-OS, prima di eseguire un aggiornamento è 
obbligatorio eseguire il Backup della configurazione dalla pagina di aggiornamento.​
A partire da vers. 5141 Rev. 0004 è possibile disabilitare la ricerca online di Firmware. 
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Factory default 
L’operazione di Factory Default riporta il sistema INFO-OS alle impostazioni di fabbrica 
(cioè alla stessa situazione di una macchina appena installata) reimpostando il file di 
configurazione e viene eseguita da: 

●​ System → Factory default​
 

In seguito al Factory default è possibile che INFO-OS si riavvii o richieda un riavvio 
manuale. 
 
Attenzione! Questa operazione può invalidare le licenze. Pertanto è da eseguire 
unicamente previa richiesta da parte di un nostro tecnico che si occuperà anche di 
assegnare le licenze al sistema.​
 
N.B.: Questa operazione non ha alcun effetto sul pool dati, ma agisce unicamente sul 
disco/volume di sistema. 
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Licence 
Nel seguente tab è possibile visualizzare le licenze assegnate al sistema. 

●​ System → Licence 
 
Esse definiscono le funzioni abilitate su di essa, come segue: 

●​ UUID: Stringa univoca assegnata al sistema, ad essa sono legate le licenze. Varia 
sia a seguito di modifiche hardware, sia in caso di reinstallazione del sistema 
operativo o di Factory Default.​
 

●​ Max Size (TB): Definisce i TeraByte di dischi raw che possono essere gestiti nei 
pool dati.​
 

●​ Maintenance: definisce la disponibilità di supporto remoto acquistato col 
sistema.​
 

●​ Send: Consente l’invio di snapshot remoti verso un altro sistema, se associati 
tramite Replication Keys.​
 

●​ Receive: Consente di ricevere snapshot da un altro sistema, se associati tramite 
Replication Keys.​
 

●​ Upgrade: Consente l’aggiornamento del Sistema Operativo.​
 

●​ Hast: Consente di configurare il sistema in Cluster HA.​
 

●​ Cache: Abilita l’utilizzo dei BOX Cache READ e WRITE MIRROR nel pool dati.​
 

●​ Virtualization: Abilita la virtualizzazione nativa tramite VBox.​
 

●​ Remote Disks: Permette a un sistema INFO-OS di gestire dischi e pool distribuiti 
su più macchine. 
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Configurazioni generali 

Setup data e ora 
È possibile configurare la data ed ora di INFO-OS sia manualmente che tramite servizio 
NTP, tramite la pagina: 

●​ System → Setup → Time 
 
Si potrà quindi specificare: 

●​ Il fuso orario (Time Zone) 
●​ Il formato di presentazione della data (Data Format) 
●​ L’orario manualmente (System Time) 
●​ Attivare e disattivare il servizio NTP 
●​ Impostare l'indirizzo web del server NTP  (NTP Time Server) 
●​ La frequenza (in minuti) con cui aggiornare l’orario tramite NTP (Time 

Synchronization)​
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Email notification 
Dalla pagina di impostazione di Email è possibile gestire il servizio di notifica tramite 
e-mail per essere informati di novità, ad esempio aggiornamenti, o ricevere segnalazioni 
di eventi. 
 
Si potrà definire per quali eventi essere notificati e modificarne i relativi parametri 
tramite: 

●​ System → Email 
 

 
 
Suggerimenti:​
Soglia pool: consigliamo di impostare la notifica “pool used space” intorno al 60% per 
diversi motivi. 

●​ Quando viene impegnato più del 60% del volume del POOL (in particolare se 
formato da SSD), si possono riscontrare cali di prestazioni. 

●​ Prevedere una parte di pool libera è sempre utile in caso di emergenza, per poter 
ospitare repliche da parte di un altro sistema, dati da salvaguardare 
momentaneamente, la copia di una VM o altro. 

●​ In base alle statistiche di normale crescita aziendale, raggiunto il 60% di impiego 
del pool è bene iniziare a valutarne l’espansione, l’aggiunta di un pool secondario, 
o simili alternative. 

●​ Il 60% è una soglia che consente di avere tempo e spazio di manovra sia per 
gestire situazioni di emergenza che per valutazioni sul sistema. 

 
N.B.: È bene ricordare che questo è un servizio di alert atto ad affiancare il normale 
controllo e manutenzione da parte dei sistemisti e NON a sostituirli.  
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Gestione dei Log 
I Log di INFO-OS segnalano le attività del sistema, eventuali avvisi e gli errori riscontrati. 
Essi possono essere gestiti e visualizzati tramite la pagina: 

●​ System → Log 
​
Tramite la sezione “Log Settings” è possibile impostare: 

1.​ L’ordine dei log (da più recente a meno recente e viceversa) 
a.​ Con la voce in “Yes” si vedranno prima i Log più recenti 

2.​ La quantità di righe nel log visibili dall’interfaccia web 
3.​ La compressione 

​
Nella sezione “Log Actions” invece, tramite il menù a tendina si può procedere alla 
selezione di quali Log vedere, scaricare e ricercare parole o frasi specifiche. 
 

 
 
Salvataggio dei Log nel POOL 
In sistemi installati in modalità Embedded, in seguito al riavvio di INFO-OS viene 
azzerata la lista dei LOG, pertanto se si desidera poter salvare e visionare i Log anche 
attraverso riavvii, spegnimenti e accensioni, è necessario fare quanto segue: 

1.​ In System → Log → Log Settings: 
a.​ Impostare "Enable reverse order" in "Yes" 
b.​ Impostare "Max Entries" a "10000" 
c.​ Salvare tramite "Save" 

2.​ Creare un Folder all'interno del POOL adibito a contenere il Log 
3.​ Dirigersi su: System → Info-OS registry → Rc - System configuration information 
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4.​ Cliccare "Add new key" 
5.​ Compilare i tre campi come segue: 

a.​ Description: descrizione della chiave, per esempio "Log backup" 
b.​ Info-OS Key: inserire: clog_logdir 
c.​ Value: <percorso del Folder sopra indicato>, per esempio: /mnt/vol1/log 

6.​ Premere la spunta verde  sulla destra per confermare la chiave ed abilitarla col 
bottone "Enable/Disable" e poi salvare con "Save" 

7.​ A questo punto è necessario un riavvio del sistema per applicare le modifiche 
 

 

 
 
Successivamente per il recupero del Log sarà sufficiente aprire i permessi del Folder 
adibito e condividerli in SMB così da poterli raggiungere e visionare. 
 
N.B.: è possibile impostare questa voce nel Registry solo nella versione 4.5.0.0 - rev. 13 
o più recenti di INFO-OS  
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Networking 
Alla prima configurazione di un sistema è fondamentale configurarne 
gli aspetti legati al Networking così che possa integrarsi 
adeguatamente nella rete dove verrà inserito. Tale configurazione 
viene effettuata tramite le apposite pagine sotto al tab ‘Network’. 

Interfaces 
Le configurazioni principali per la gestione delle interfacce di rete 
vengono svolte tramite la pagina: 

●​ Network → Interfaces 

Hostname 
l’Hostname è il nome con il quale il NAS si pubblica nella rete. È raccomandato l’utilizzo 
di un Hostname univoco per ogni sistema. 
 

 

DNS 
I DNS vengono autocompilati nel caso le schede di rete siano impostate in DHCP, 
mentre andranno compilate nel caso le schede siano impostate in modalità Static. 
È sempre bene verificare che i DNS siano impostati correttamente, anche in caso di 
DHCP. 
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LAN Ethernet 
In questa pagina vengono mostrate le interfacce di rete che sono state abilitate all’uso. 
È possibile assegnare un’interfaccia diversa a svolgere una determinata funzione 
tramite la tendina che ne indica nome e MAC Address. 
È possibile aprire la pagina di modifica dei parametri di una specifica interfaccia tramite 
gli ingranaggi sulla destra. 
È inoltre possibile aggiungere/attivare nuove interfacce tramite il tasto [+] sulla destra. 
 

 
 
L’aggiunta di una nuova interfaccia prevede che le venga assegnata una scheda di rete 
indicata nella tendina con nome e MAC Address. 
 

 
 
Si andranno poi ad assegnare i parametri desiderati alla nuova interfaccia di rete. 
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Nello specifico, sarà possibile impostare un nome descrittivo all’interfaccia in questione 
(OPT1 di default) e si potrà definire la modalità di acquisizione dell’IP, scegliendo fra 
DHCP e Static. 
 

 
 
Selezionando Static sarà necessario compilare i campi proposti. È bene assicurarsi di 
non impostare all’interfaccia un IP già in uso nella rete. 
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È buona norma impostare in full-duplex l’interfaccia tramite l’apposita tendina Duplex 
che si trova negli Advanced Settings. 

 
 
N.B.: se si decide di modificare il valore MTU, è bene tenere a mente che se sono presenti 
VLAN è prima di tutto necessario modificare il valore MTU della scheda di rete fisica ad 
esse associate. Le VLAN devono avere MTU uguale o inferiore alla scheda di rete fisica su 
cui poggiano. 
 
Opzioni aggiuntive 
A partire dalla Vers. 4.5.0.0 - Rev. 0031 è possibile assegnare parametri aggiuntivi dalla 
pagina “Advanced Settings” nel campo “Extra options”. 
 
N.B.: errori nell’inserimento di parametri o l’inserimento di parametri non supportati dalla 
scheda di rete potrebbe inficiare il funzionamento del sistema e renderlo instabile o 
inutilizzabile. 
 
Di seguito alcuni parametri consigliati in caso si riscontrino instabilità di rete (tentare 
prima l’opzione più semplice e solo nel caso non fosse risolutiva applicare la seconda): 

●​ -rxcsum -txcsum 
●​ -rxcsum -txcsum -vlanhwtso -lro -tso4 -tso6 
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In revisioni di INFO-OS precedenti a quella sopra indicata, è possibile aggiungere questi 
parametri aggiuntivi come segue: 

1.​ Scaricare il file configurazione tramite: 
○​ System → Backup → [Download Configuration] 

2.​ Aprire con un Text editor (come Notepad++) il file di configurazione 
3.​ Cercare la zona riguardante le schede di rete "interfaces" (<interfaces>) 
4.​ Identificare l’Interfaccia desiderata (nel ns. esempio “igb0” assegnata a LAN <lan>) e 

aggiungere ai parametri (<extraoptions>) le seguenti opzioni (tentare prima l’opzione 
più semplice e SOLO nel caso non fosse risolutiva applicare la seconda): 
○​ -rxcsum -txcsum​

Es.: <extraoptions>-rxcsum -txcsum</extraoptions> 
○​ -rxcsum -txcsum -vlanhwtso -lro -tso4 -tso6​

 Es.: <extraoptions>-rxcsum -txcsum -vlanhwtso -lro -tso4 -tso6</extraoptions>​
N.B.: Se non dovesse essere presente la riga: <extraoptions></extraoptions>, è 
sufficiente aggiungerla come nuova riga sotto alla voce <mtu>.​
N.B.2: Nel caso si stia utilizzando VLAN, è necessario modificare anche 
l'Interfaccia a cui è associata la scheda di rete FISICA su cui la VLAN poggia. 

5.​ Salvare il file modificato 
6.​ Ricaricare la configurazione appena modificata tramite:  

○​ System → Restore​
 N.B.3: Il sistema richiederà il riavvio per applicare le modifiche 

Qui uno screenshot del file modificato: in verde si evidenzia la sezione delle interfacce, 
in azzurro l'interfaccia “LAN” a cui è associata la scheda di rete “igb0” e in arancione i 
parametri aggiuntivi. 
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VLAN 
Alla voce VLAN è possibile configurare determinate interfacce di rete all’utilizzo di VLAN 
allo scopo di isolare il traffico di rete per quella determinata porta su quella determinata 
Lan virtuale.  
 
Per creare nuove connessioni VLAN sarà sufficiente premere il bottone [+] e 
configurarne i parametri. 
 

 

 
 
Tale nuova interfaccia sarà dunque presente e potrà essere selezionata per l’utilizzo in 
LAN Ethernet tramite l’apposita tendina di scelta insieme agli altri MAC Address. 
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LAN Aggregate 
Alla voce LAN Aggregate è possibile visualizzare eventuali aggregati di porte di rete, se 
presenti, e impostarne di nuovi tramite l’apposito bottone [+] 
 

 
 
Per creare un nuovo aggregato sarà necessario assegnare il nome dell'interfaccia che 
verrà creata, per esempio lagg0. Andrà poi definito il tipo di protocollo in uso, scegliendo 
fra LACP, Failover, Loadbalance, Roundrobin, None. 
 
N.B.: è sempre bene tenere presente che determinati tipi di aggregazione richiedono 
Switch appositi per poter funzionare. 
 
Sarà infine possibile selezionare le porte di rete da aggregare fra quelle proposte 
(CTRL+Click) 
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Il nuovo aggregato verrà quindi presentato nel menù LAN Aggregate dal quale potrà 
sempre essere modificato o cancellato. 
 

 
 
Tale nuova interfaccia sarà dunque presente e potrà essere selezionata per l’utilizzo in 
LAN Ethernet tramite l’apposita tendina di scelta insieme agli altri MAC Address.
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Gestione Web Interface 
È possibile configurare il protocollo di rete (HTTP, HTTPS) della Web Interface tramite: 

●​ System → Setup → Web Interface 
 

 

Configurazione interfacce tramite console 
Tramite la console è possibile modificare le impostazioni relative all’uso delle interfacce 
di rete. 
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Premendo 1 (Configure Network Interfaces) 
Si aprirà un wizard di configurazione con la quale si potrà determinare quali schede di 
rete rendere attive.  
 
Partendo dall'interfaccia principale (LAN) verrà richiesto quale scheda di rete fisica 
assegnare all’interfaccia, se attivarne più di una, se fare un auto-selezione in base alle 
porte collegate o se completare/interrompere la configurazione. 
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Premendo 2 (Configure Network IP Address) 
Si potrà invece configurare l’indirizzo IPv4 e IPv6 (statico, DHCP, disattivato) delle 
schede di rete seguendo il Wizard proposto a video. 
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Riavvio servizio Web Interface 
In alcuni casi, come per esempio errori ripetuti di accesso/comunicazione di rete o 
sovraccarico delle risorse di sistema, è possibile che la pagina Web di gestione di 
INFO-OS diventi non responsiva.  
 
In questi casi prima di optare per un riavvio di sistema è possibile tentare di riavviare il 
servizio di Web Interface tramite la console (‘desktop’ INFO-OS) digitando “12” e 
premendo INVIO. 
 

 
 
 
A partire da vers. 5141 di INFO-OS il menù è più espanso: 
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Inserimento INFO-OS in dominio Windows 
Di seguito i passaggi necessari all’inserimento di un sistema INFO-OS in un Dominio 
Windows. 
 
Innanzitutto è necessario modificare il tipo di autenticazione ai folder condivisi da Local 
User a Active Directory: 

●​ Services → CIFS/SMB → Edit  → Authentication → Active Directory 
 
N.B.: Il NetBIOS Name richiesto è il nome della macchina INFO-OS, NON deve essere 
uguale al nome del dominio (DC) per non creare problemi. Il NetBIOS Name è quello che 
identifica lo storage nella rete e tramite il quale si possono raggiungere le cartelle 
condivise, usandolo in alternativa all'IP. 
 
Successivamente, se si prevede di condividere Folder tramite protocollo SMB, in 
Advanced Settings impostare: 

●​ “EA Support” su Enable utilizzando il relativo visto  
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In seguito si potrà inserire INFO-OS nel Dominio: 
●​ Network → Active Directory → Compilare i parametri e salvare 

 
È possibile controllare il corretto inserimento nel Dominio tramite il pulsante Check 
status. 
 

 
 
Note sui parametri: 

●​ Domain Controller Name: nome del computer del Server di Dominio (DC). ​
Esempio: SRV-DP00 (deve essere in MAIUSCOLO) 

●​ Domain Name (DNS/Realm-Name): nome del dominio.​
Esempio: test.domain (deve essere in minuscolo) 

●​ Domain Name (NetBIOS-Name): è il nome del dominio in formato pre-Windows 
2000, generalmente identico alla parte iniziale del Domain Name 
(DNS/Realm-Name).​
Esempio: TEST (deve essere in MAIUSCOLO) 

 
N.B.: È bene riavviare il servizio Active Directory sul server di Dominio Windows dopo aver 
effettuato il join tramite INFO-OS, assicurandosi che l’operazione sia avvenuta con 
successo. 
 
Fare riferimento a INFO-OS Active Directory (sotto Windows Domain) per la 
configurazione di condivisioni di rete in SMB. 
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Creazione di utenti e gruppi 
Se il sistema INFO-OS non è associato ad un dominio, è possibile gestire gli accessi ai 
Dataset condivisi tramite Utenti e Gruppi di INFO-OS. 

Creazione di un gruppo 
È possibile visualizzare i gruppi predefiniti (indicati con lucchetto), quelli esistenti e 
crearne di nuovi, tramite: 

●​ Users → Groups 

 
 
La creazione di un gruppo richiede un nome, un ID che INFO-OS assegnerà 
automaticamente in maniera sequenziale, e eventualmente una descrizione con 
informazioni utili al riconoscimento. 

 
Una volta aggiunto il gruppo esso comparirà nell’elenco assieme agli altri, lasciando la 
possibilità di modificarlo successivamente tramite l’apposito pulsante.  
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Creazione di un utente 
Tramite: 

●​ Users → Users 
è possibile visualizzare gli utenti esistenti, modificarne i parametri e crearne di nuovi  
 

 
 
Durante la creazione di un nuovo utente verranno mostrati i seguenti parametri: 

●​ Name: Nome che verrà richiesto per il login. 
●​ Full Name: nome per esteso, può essere uguale a “Name”. 
●​ Email: indirizzo mail dell’utente (opzionale). 
●​ Password: password dell’utente che si sta creando, verrà richiesta per il login. 
●​ Confirm Password: deve coincidere con il campo precedente. 
●​ User ID: numero identificativo univoco assegnato all’utente da INFO-OS, 

lasciando il default proposto INFO-OS li assegnerà in maniera incrementale. 
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In Advanced Settings si imposteranno poi: 
●​ Primary group: gruppo principale nel quale verrà inserito l’utente. 
●​ Additional Group: eventuali gruppi secondari in cui inserire l’utente ​

(ctrl+click per selezionare più elementi). 
●​ Enable Portal: abilita l’utente all’accesso alla web interface. 

 

 
 
Terminata questa configurazione, l’utente comparirà nell’elenco assieme agli altri. 
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Gestione dei dischi 
È possibile verificare lo stato dei dischi dello Storage navigando in: 

●​ Data → Disks Manager 
 

 
 
In caso di aggiunta di dischi sarà necessario utilizzare il comando Rebuild per 
aggiornare la lista dei dischi visualizzati. 
 

 
 
Nel caso dovesse essere necessario formattare uno o più dischi si potrà o selezionare 
“Format All” formattando così tutti i dischi (tranne quello del sistema operativo OS) 
oppure selezionare il singolo disco interessato e premere l’apposito bottone “Format”. 
 
È possibile che l’operazione venga bloccata nel caso uno o più dischi che si desidera 
formattare sia contenuto all’interno di un POOL importato, per risolvere sarà necessario 
esportare/cancellare il POOL o/e modificarlo in modo da rendere libero (“Available”) i 
dischi in questione. 
 
Infine, sempre dalla pagina di Disks Manager è possibile eseguire il “Blink” dei dischi 
così da poterne riconoscere la posizione fisica nel server. 
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Associazione dei dischi 
Nella pagina di Disks Manager è possibile verificare quale ruolo sta svolgendo un 
determinato disco leggendo quanto riportato tra parentesi di fianco al nome dello 
stesso. 

 
Generalmente in seguito a guasti hardware, è possibile che tali diciture non siano più 
accurate. Per aggiornare e ottenere una corretta visualizzazione, andare in: 

●​ Data → Folders - Virtual disks 
○​ E eseguire una ricaricamento delle risorse 
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Creazione e management di un Pool 
I Pool possono essere creati, gestiti e importati tramite la pagina: 

●​ Data → Pools Manager 
 

 
 
Nella fase di creazione di un Pool verranno visualizzati tutti i dischi disponibili all’uso. 
Selezionando i box desiderati e trascinando al loro interno i dischi disponibili si andrà a 
determinare la struttura del pool (STRIPE, RAID e CACHE): 
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Definizione dei “box” 
●​ STRIPE: con questa configurazione si disporrà della massima capacità dei dischi 

inseriti, ma non si avrà alcun tipo di ridondanza. ​
In caso di avaria di anche un solo disco non si potrà ricostruire il pool. 

●​ MIRROR: con questa configurazione metà dei dischi del Pool saranno utilizzati 
per ridondanza. Finché almeno metà dei dischi funziona, i dati saranno 
utilizzabili. 

●​ RAIDZ1: questa configurazione usa una suddivisione dei dati a livello di blocchi 
dinamici, distribuendo i dati di parità uniformemente tra tutti i dischi che lo 
compongono. È quindi possibile la perdita di un disco prima della perdita dei dati.​
La capacità utilizzabile sarà pari al numero di dischi meno uno. ​
Servono almeno 3 dischi per utilizzare questa configurazione.  

●​ RAIDZ2: questa configurazione suddivide i dati in maniera simile a un RAIDZ1 ma 
consente la perdita di due dischi prima della perdita dei dati.​
La capacità utilizzabile sarà pari al numero di dischi meno due. ​
Servono almeno 4 dischi per utilizzare questa configurazione.  

●​ RAIDZ3: questa configurazione suddivide i dati in maniera simile a un RAIDZ1 ma 
consente la perdita di tre dischi prima della perdita dei dati.​
La capacità utilizzabile sarà pari al numero di dischi meno tre. ​
Servono almeno 5 dischi per utilizzare questa configurazione.  

●​ SPARE: i dischi inseriti in questo “box” verranno utilizzati automaticamente dal 
Pool per la ricostruzione dei dati nel caso di avaria di uno dei dischi principali. 

●​ CACHE R: i dischi inseriti in questo “box” verranno utilizzati come READ CACHE. 
●​ CACHE WM: i dischi inseriti in questo “box” verranno utilizzati come WRITE 

MIRROR CACHE. Per una maggiore sicurezza del dato in questa configurazione i 
dischi sono posti in MIRROR. 

 
Una volta creato il Pool si potrà facilmente visualizzare il suo stato e modificarne le 
proprietà tramite l’apposito bottone a forma di ingranaggio: 
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Cancellazione o Esportazione di un POOL 
Per esportare o cancellare un POOL è necessario innanzitutto rimuovere eventuali 
condivisioni di rete (SMB, AFP, NFS, ISCSI) e schedulazioni di Snapshot che si ha creato. 
In alcune configurazioni sarà anche richiesto/necessario rimuovere tutti gli Snapshot 
presenti nei Dataset contenuti dal POOL. 
 
Dopodiché ci si potrà dirigere in: 

●​ Data → Pools Manager → [POOL interessato] → Edit  
○​ Per cancellare il POOL si potrà poi premere Delete 

 
○​ Per esportare il POOL si potrà poi premere Export 

 
 
Nel caso si proceda con la cancellazione (“Delete”) tutti i dati contenuti nel POOL 
verranno eliminati, mentre se si procede con l’Export si potrà procedere in un secondo 
momento o da un altra appliance INFO-OS all’importazione (“Import”) dello stesso con 
tutti i dati contenuti al suo interno. 
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Gestione di un POOL degradato 
In caso di avaria del POOL ci si può trovare di fronte a diversi scenari. Generalmente 
nella vista di gestione del POOL apparirà un'area gialla e il disco guasto in questione 
sarà evidenziato in rosso se rotto o in blu con lente se mancante. È possibile che un 
disco mancante appaia come rotto, in rosso. 
 
In base alla situazione in cui ci si trova si possono verificare due scenari: 

●​ Se sono già presenti dischi a disposizione per sostituire quello in avaria: sarà 
necessario trascinare uno dei dischi disponibili e il disco guasto/mancante 
all’interno della zona gialla poi cliccare su Repair nell’Edit del Pool. 

 
●​ Se invece si inserisce un nuovo disco nello slot precedentemente occupato da 

quello in avaria: 
○​ Data → Disk Manager → Rebuild​

Per verificare che il disco nuovo sia visto correttamente dal sistema. 
○​ Data → Pool Manager → Edit → ​

Sarà sufficiente premere “Repair” senza trascinare dischi nell'area gialla.​
​
N.B.: in alcune casistiche il disco guasto sarà comunque mostrato nella lista 
dei dischi del POOL e sarà riconoscibile per via del nome, che mostrerà una 
lunga stringa di numeri al posto del nome più ‘tradizionale’ (ada* ; da*), in 
questo caso sarà necessario trascinare il nuovo disco ed il disco rotto (che 
ha stringa per nome) nell’area gialla prima di cliccare Repair. 

 
Le operazioni descritte sono effettuabili con il sistema in funzione, pertanto non 
necessitano di un fermo macchina. In seguito al Repair sarà necessario attendere e 
monitorare il rebuild del disco, finché lo stato del pool non passerà da DEGRADED a 
OPTIMAL.​
N.B.: La ricostruzione avverrà in background, in secondo piano rispetto ad altre attività di 
lettura/scrittura. 
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POOL con Spare 
Nel caso all’interno del POOL si disponga di un disco collocato nel box Spare, in caso di 
guasto di uno dei dischi facenti parte dei box principali, questo interverrà in automatico 
rimpiazzando il guasto così da assicurare la ridondanza del POOL. 
 
Dopodiché il POOL resterà in stato degradato finché il disco guasto non verrà sostituito 
e, una volta sostituito, il nuovo disco prenderà il posto del disco guasto mentre lo Spare 
attualmente in uso tornerà nel suo box originale a fungere nuovamente da Spare. 
 
In questo caso, quindi, non sarà necessario nessun intervento manuale all’infuori della 
sostituzione fisica del disco guasto. 
 
N.B.: È sempre consigliato monitorare la situazione finché il POOL non è tornato 
completamente online e sano. 
 

 
 
Di seguito un esempio di un guasto in un POOL con Spare: 
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Il disco ada2 si guasta: 

 
Il disco ada4 (Spare) entra automaticamente nel POOL sostituendo ada2 (guasto):
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Sostituendo il disco ada2 fisicamente inizia automaticamente il processo di 
ricostruzione (Resilver) del POOL definitivo: 

 
Una volta terminata la ricostruzione ada4 torna ad essere un disco Spare e il POOL 
torna in stato ONLINE: 
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Remote disks 
La licenza “Remote Disks” permette di collegare dischi virtuali tramite protocollo iSCSI 
all’Host INFO-OS. Questi dischi saranno poi utilizzabili per la creazione di POOL. 
 
Per collegare un disco in iSCSI è necessario dirigersi su: 

●​ Network → iSCSI → Initiator▼ 

 
Qui tramite il bottone “+” si potranno aggiungere dischi virtuali remoti all'iniziatore iSCSI 
inserendo il nome identificativo, l’IQN e l’indirizzo dei relativi Target iSCSI. 
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In seguito tramite un riavvio di INFO-OS o premendo l’apposito bottone di collegamento 
si potrà tentare la connessione al disco. 
 
N.B.: in alcune casistiche potrebbe essere necessario riavviare il servizio iSCSI tramite: 

●​ Services → iSCSI → Restart  
Oppure riavviare l’intero sistema INFO-OS 

 

 
 
Una volta confermata la corretta connessione al/ai dischi remoti, questi saranno visibili 
ed utilizzabili tramite la pagina di modifica/creazione di POOL. 
 
N.B.: è possibile creare POOL “ibridi” di dischi fisici “locali” e dischi remoti ed è anche 
possibile creare POOL con dischi remoti di diversi Target iSCSI. 
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Creazione e gestione di Dataset 
In INFO-OS i Dataset sono entità logiche che rappresentano una porzione del POOL di 
archiviazione e possono essere creati per rappresentare un file system completo o una 
porzione di esso, ad esempio una cartella o sottocartella. 
 
I Dataset sono molto flessibili e consentono di organizzare i dati in modo logico ed 
efficiente. Ogni Dataset può avere diverse proprietà, come la compressione dei dati, 
l’utilizzo di cache, la deduplicazione e la quota di spazio massimo.  
 
Infine, a differenza di cartelle e sottocartelle “tradizionali”, disponendo di filesystem, i 
Dataset possono eseguire operazioni avanzate, come gli Snapshot, Clonazione e 
Repliche (locali e remote) dando la possibilità al sistema INFO-OS di fungere da 
soluzione completa di backup, Disaster Recovery e Data manager. 
 
La gestione dei contenuti del Pool, cioè Dataset, viene effettuata dalla pagina: 

●​ Data → Folders - Virtual disks 
 
Qui si avrà visione dei contenuti sotto la voce “Resources”: il Dataset principale sarà il 
Pool e al suo interno sarà presente di default un Folder “Clones” dove verranno inseriti i 
Folder clonati e all’interno del Pool si potranno creare i Dataset da utilizzare. 
 

 
 
N.B.: Quando si creano Folder e/o Virtual Disk, questi saranno inseriti all’interno del Pool o 
Folder attualmente selezionato al momento della pressione del bottone di creazione. 
Generalmente è consigliato creare Folder e Virtual Disk all’interno della root del Pool 
evitando quindi nidificazioni.  
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Creazione di un Folder 
Per creare un Folder è sufficiente premere l’apposito bottone come segue: 

●​ Data → Folders - Virtual disks → [Pool/Folder interessato] → +Folder 
 

 
 
Durante il processo di creazione verranno richieste le informazioni ed impostazioni di 
base da dare al Folder. 
Le principali ed importanti da assegnare durante la creazione poiché non modificabili 
successivamente sono: 

●​ Name: definisce il nome del Folder 
●​ Case sensitivity: determina se il sistema operativo deve distinguere tra lettere 

maiuscole e minuscole nei nomi dei file e delle sottocartelle.  
 
In dettaglio riguardo a quest’ultima opzione: 
In un Folder case-sensitive (dove cioè il parametro è impostato su: “Sensitive”) un file 
chiamato "File.txt" e un file chiamato "file.txt" sarebbero considerati due file distinti, 
mentre nella maggior parte dei Folder non case-sensitive (parametro su: “Insensitive”) 
sarebbero considerati lo stesso file. 
In alcuni sistemi operativi, come Linux e macOS, le cartelle sono case-sensitive per 
impostazione predefinita, mentre in altri, come Windows, le cartelle sono generalmente 
non case-sensitive, ma possono essere create cartelle case-sensitive se necessario. 
 
Dove sistemi operativi case-sensitive lavorano correttamente in Folder case-insensitive 
lo stesso non è sempre vero nel caso contrario. 
Pertanto si consiglia di rendere i Folder case-insensitive (quindi di impostare il 
parametro su: “Insensitive”) per garantire maggiore compatibilità con sistemi Windows 
in caso di condivisione del Folder. 
 
Per ulteriori dettagli sugli altri parametri, vedi: Modifica dei parametri di un Dataset 
(Folder o Virtual Disk) 
 
N.B.: É raccomandato lavorare con Folder e Virtual Disk creati nella root del pool, senza 
creare nidificazioni di subfolder. La creazione di subfolder, a seconda dell’utilizzo e delle 
impostazioni, può generare problemi di sorta come incongruenze dei permessi nelle 
condivisioni e ricorsività degli snapshot e repliche. 
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Creazione di un Virtual Disk 
Per creare un Virtual Disk è sufficiente premere l’apposito bottone come segue: 

●​ Data → Folders - Virtual disks → [Pool/Folder interessato] → +Virt. Disk 
 

 
 
Durante il processo di creazione verranno richieste le informazioni ed impostazioni di 
base da dare al Virtual Disk. 
Di seguito le impostazioni più importare da assegnare alla creazione poiché non 
modificabili successivamente (ad eccezione di Size (G)): 

●​ Name: definisce il nome del Virtual Disk 
●​ Size (G): definisce la grandezza del disco virtuale in GigaByte e può essere 

modificata dopo la creazione del Virtual Disk. 
●​ Block size: si riferisce alla dimensione dei blocchi di dati utilizzati per 

memorizzare e organizzare i dati sul disco virtuale. ​
Un block size più grande può consentire una maggiore efficienza nella lettura e 
scrittura di grandi file, ma può anche portare a uno spreco di spazio. Al contrario, 
un block size più piccolo può consentire una maggiore precisione nell'allocazione 
dello spazio, ma può rallentare le operazioni di lettura e scrittura. 

●​ Thin: definisce se il disco virtuale utilizzerà l’allocazione di tipo Thin (Yes) o Thick 
(No) provisioning.​
Thick provisioning prevede l'allocazione immediata di tutto lo spazio richiesto per 
un determinato volume di storage, indipendentemente dal fatto che questo 
spazio venga utilizzato o meno. Lo spazio viene quindi riservato all'interno del 
sistema di storage e non può essere utilizzato per altre forme di dati. Questa 
opzione può essere più performante in alcune situazioni. 
Thin provisioning, invece, consente di allocare lo spazio richiesto solo quando 
effettivamente viene utilizzato. In questo modo, lo spazio sul disco viene allocato 
in modo dinamico, in base alle effettive esigenze, utilizzando quindi lo spazio in 
modo più efficiente. 

 
Per ulteriori dettagli sugli altri parametri, vedi: Modifica dei parametri di un Dataset 
(Folder o Virtual Disk) 
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Modifica dei parametri di un Dataset (Folder o Virtual Disk) 
Per modificare le proprietà e parametri di un Folder o Virtual Disk esistenti andare in: 

●​ Data → Folders - Virtual disks → [Dataset interessato] → Edit  

 

 
 
Di seguito alcune descrizioni e raccomandazioni sulla configurazione dei parametri: 

●​ Quota (G): disponibile nei Folder, consente di specificare una quota limite in 
GigaByte della grandezza del Folder. Impostandolo, il Folder non potrà occupare 
più spazio di quanto indicato in questo parametro. 

●​ Reservation (G): disponibile nei Folder, consente di specificare in GigaByte spazio 
sul disco da riservare così che non venga utilizzato da altri Folder o Virtual Disk. 

●​ Snapshot directory: disponibile nei Folder, nel caso di condivisione del Folder, 
permette di vedere (Visible) o nascondere (Hidden) la cartella di INFO-OS 
contenente gli Snapshot. È consigliato lasciare il default: Hidden. 

●​ ACL inherit: disponibile nei Folder, definisce il metodo di ereditarietà delle ACL 
Unix. 

●​ Compression: di default impostato su “Very high performance, low space savings 
using LZ4 (recommended)” quando attivo, comprime automaticamente i dati 
contenuti nel Folder. È consigliato mantenere il default e assegnare a tutti i 
Folder creati la medesima impostazione di compressione. 

●​ Cache write: di default impostato su “Standard” gestisce la modalità di scrittura e 
l’utilizzo della Cache. Quando impostato su “Disabled” si avrà il massimo delle 
performance. Se impostato in “Standard” si avrà una scrittura sincrona dei dati 
su Cache e storage. Se impostato in “Always” il dato verrà sempre scritto su 
storage stabile per prevenire la perdita di dati con conseguenti riduzioni di 
performance (raccomandata solo in caso di utilizzo di sistema High Availability). 

●​ Dedup: di default impostato su “Off”, gestisce la possibilità di deduplicare i dati, 
identificando e rimuovendo i dati doppi. Per il suo utilizzo sono necessari 5 GB di 
RAM per ogni TeraByte deduplicato e alta capacità prestazionale 
computazionale. 

●​ Note: disponibile nei Folder dopo la loro creazione, consente di inserire delle note 
e commenti sotto forma di testo semplice.  
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Condivisione di un Folder in SMB 
Per condividere un folder in SMB: 

●​ Data → Folders - Virtual disks → [Folder interessato] → SMB Share 
○​ Impostare i parametri di condivisione e cliccare su “Save changes and 

share” 
 

 
 

Gestione dei permessi 
Relativamente ai permessi è importante definire la differenza tra Dataset e Cartelle. ​
I Dataset sono i Folder e i Virtual Disk creati, gestiti e condivisi da INFO-OS, che ne 
definisce quindi i permessi. Mentre le Cartelle sono quelle che vengono create dagli 
utenti, ad esempio tramite Windows, all’interno dei Dataset condivisi. I permessi delle 
Cartelle vengono quindi gestiti dall’utente Windows che le ha create. 
 
Questa distinzione è importante poiché con INFO-OS si possono gestire i permessi dei 
Dataset come segue: 

●​ Data → Folders - Virtual disks → [Dataset interessato] → Access control 
○​ Owner: cioè il proprietario del Dataset, generalmente avrà tutti i flag attivi 

(Read, Write, Execute) per il controllo e gestione del Dataset.  
○​ Group: definisce il gruppo di appartenenza del Dataset ed i relativi 

permessi. 
○​ Other: definisce i permessi di utenti che non sono Owner e non fanno 

parte di Group. 
 
Quando invece si creano Cartelle all'interno dei Dataset condivisi, le loro proprietà 
verranno gestite dal loro creatore (ad esempio utente Windows che ha creato tale 
cartella). 
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A partire da Vers. 5141 Rev. 1020 è stata espansa la pagina Access control ed è ora 
possibile configurare parametri avanzati di permessi ed è anche possibile aggiungere 
entità all’infuori degli standard “Owner” e “Group”.  
 
Definendo prima le entità ‘standard’ quali owner@ e group@ dalla sezione “Ownership”, 
si potranno poi assegnare permessi specifici tramite la sezione “Access Control Rules” 
e aggiungere ulteriori entità. 
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Questa maggiore granularità aiuta sia nel caso di necessità di ripristino dei permessi 
avanzati che nei casi in cui i Client in uso non siano basati su Windows ma su altri 
sistemi Unix e Unix-like (Linux, macOS) e si vuole ricorrere alla gestione dei permessi 
interamente tramite INFO-OS. 
 
N.B.: Salvando ricorsivamente le modifiche si andranno ad applicare i permessi impostati 
anche a tutti i contenuti del Folder. 
 
N.B.2: Modificando i permessi da “Permissions” è possibile sovrascrivere quanto 
impostato nella sezione “Access Control Rules” e viceversa.  
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Nel caso in cui si modifichino i permessi di Folder, file o cartelle tramite Windows, questi 
non saranno più determinati dall’ereditarietà imposta dal Dataset di INFO-OS, ma 
saranno determinati da Windows. Nello specifico, una volta modificati, i permessi 
ereditati saranno SOLO quelli modificati tramite Windows, quelli non modificati NON 
saranno presenti nella lista dei permessi. 
 
Se l’oggetto di modifica dei permessi è una Cartella, se NON si attiva l’opzione “Si 
applica a: La cartella selezionata, le sottocartelle e i file” - in Proprietà di Sicurezza 
avanzate Windows, i permessi di file e sottocartelle create all’interno NON riceveranno i 
permessi né da INFO-OS (poiché sovrascritti da Windows) né da Windows (poiché 
l’ereditarietà non è attiva) e potrebbero quindi risultare inutilizzabili. 
 
Per esempio, quando si modificano i permessi di una cartella che nella lista dei 
permessi dispone di Utente1, Gruppo1 e Everyone, se si modifica solo Utente1 le 
sottocartelle che si andranno a creare erediteranno solo Utente1 mentre Gruppo1 e 
Everyone NON saranno presenti in lista. 
 
Il consiglio è quindi quello di modificare i permessi di tutte le voci anche solo abilitando 
la voce “Si applica a: La cartella selezionata, le sottocartelle e i file” per renderli 
ereditabili. 
​
Similarmente, una volta attivata l’opzione sopra indicata, NON si deve selezionare la 
spunta in basso “Applica queste autorizzazioni solo ad oggetti e/o contenitori in questo 
contenitore”, poiché altrimenti le autorizzazioni verranno applicate solo al primo livello 
della cartella e si potrebbe incorrere in errori durante la creazione di sottocartelle. 
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Gestione accesso e configurazioni raccomandate 
Riguardo all’accesso del Folder, se in Access control “Others” è abilitato almeno a 
lettura “Read”, si può definire se permettere l’accesso al Folder anche ad utenti non 
autenticati, tramite la seguente opzione: 

●​ Data → Folders - Virtual disks → [Folder interessato] → SMB share 
○​ Guest access 

 
N.B.: Generalmente i client Windows tenteranno l’accesso utilizzando le proprie credenziali 
in automatico, pertanto se: 

●​  “Guest access” dovesse essere attivo [Yes] e  
●​ “Others” in “Access control” non dovesse avere alcun permesso attivo,  

quando si eseguirà l’accesso questo verrà negato senza richiesta di nome utente e 
password, sarà quindi necessario collegare come unità di rete il Folder, abilitando il flag 
“Connetti con credenziali diverse”. 
 
È bene tenere anche a mente che la voce Recycle bin nella pagina di condivisione è una 
funzione nativa di SMB che crea un ‘cestino’ in cui verranno inseriti tutti i file eliminati. 
 
Per svuotarlo è necessario accedere alla cartella come proprietario della stessa, ciò 
potrebbe risultare complicato in alcune configurazioni, consigliamo quindi di 
disabilitarlo poiché gli Snapshot svolgono una funzione equivalente ma più avanzata e 
sono compatibili anche con Shadow copy (versioni precedenti). 
 
N.B.2: In caso di difficoltà ad accedere ai Folder condivisi in SMB, consigliamo di 
connettere come unità di rete il Folder in questione o/e di tentare un riavvio del servizio 
CIFS/SMB tramite la pagina Services. 
 

 
 
In base alla configurazione che si vuole andare a creare si possono configurare i 
parametri di condivisione SMB in diversi modo, di seguito alcuni esempi in base alle 
casistiche specifiche: 
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INFO-OS Workgroup (Local User) 
Quando INFO-OS non fa parte di un dominio Windows, per gestire gli accessi e i 
permessi sarà necessario creare gli Utenti ed i Gruppi direttamente su di lui. 
 
Una volta fatto ciò è consigliato adibire un Utente a ruoli amministrativi rendendolo 
Owner dei Folder condivisi così che possa definirne i permessi nel caso sia necessario. 
 
Per via delle differenze tra i permessi di INFO-OS e di Windows è possibile configurare i 
parametri in diversi modi in base a quel che si vuole configurare. 
 
Di seguito la configurazione ideale nel caso si vogliano sfruttare i permessi nativi di 
INFO-OS:  

●​ Services → CIFS/SMB → Edit → Advanced Settings 
○​ Abilitare la voce: EA Support 
○​ Abilitare la voce: Store DOS Attributes 
○​ Abilitare la voce: Mapping DOS Attributes 

 
●​ Data → Folders - Virtual disks → [Folder interessato] → SMB share 

○​ Impostare “NTFS ACLs:” su “No” 
○​ Impostare “ZFS ACL:” su “No” 
○​ Impostare “Permission inheritance:” su “Yes” 
○​ Impostare “Enable ACL inheritance:” su “Yes” 
○​ Impostare il resto delle configurazioni in base ai propri bisogni e salvare 

ed eseguire lo Share del Folder. 
​
In questo modo, l’Owner, il gruppo (Group) e Everyone (Others) (indicati in Access 
control) ed i loro permessi verranno ereditati automaticamente da file e sottocartelle 
creati all’interno del Folder condiviso. 
 
Tuttavia con questa configurazione non sarà possibile modificare i Permessi tramite 
Windows, questo significa che non si potranno aggiungere altri Utenti o Gruppi 
individualmente ai Permessi del Folder ed i suoi contenuti. Per far ciò quindi si dovrà 
aggiungere Utenti all’interno del Gruppo di INFO-OS che ha i permessi nel Folder. 
 
Questa è quindi un ideale configurazione per infrastrutture medio-piccole che 
dispongono di poche regole di autorizzazioni e permessi. 
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Nel caso si voglia controllare i permessi tramite Windows invece, si consiglia la 
seguente configurazione: 

●​ Data → Folders - Virtual disks → [Folder interessato] → SMB share 
○​ Impostare “Guest access:” su “No” 
○​ Impostare “NTFS ACLs:” su “Yes” 
○​ Impostare “ZFS ACL:” su “Yes” 
○​ Impostare “Permission inheritance:” su “Yes” 
○​ Impostare “Enable ACL inheritance:” su “Yes” 
○​ Impostare il resto delle configurazioni in base ai propri bisogni e salvare 

ed eseguire lo Share del Folder. 
 
Come nella casistica precedente, quanto indicato in Access control verrà 
automaticamente ereditato. 
 
È possibile che in base alle versioni di Windows e di SMB utilizzati alcuni permessi non 
vengano ereditati allo stesso modo, per esempio è possibile che i permessi del gruppo 
ereditati da sottocartelle e file non siano completi (solo controllo parziale anziché 
totale). 
 
In questi casi si consiglia di modificare i permessi tramite Windows, preferibilmente 
utilizzando l’Utente Owner del Folder che abbiamo adibito come amministratore della 
rete, prendendone il pieno controllo. 
 
N.B.: Per via di quanto già spiegato nel capitolo precedente (Gestione dei permessi) si 
consiglia di verificare il comportamento di ereditarietà dei permessi nella propria 
rete/infrastruttura ed eventualmente modificare tramite Windows tutti i permessi (anche di 
Everyone) del Folder alla sua prima configurazione. 
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INFO-OS Active Directory (sotto Windows Domain) 
Quando INFO-OS fa parte di un Dominio Windows Server, eredita da esso gli utenti ed i 
gruppi (salvo non gli venga negato dal DC) così che possa gestire gli accessi ai Dataset 
condivisi. 
 
Questa possibilità diventa particolarmente rilevante quando si condivide un Folder in 
SMB tramite INFO-OS, poiché si potrà impostare come Owner l'utente Administrator del 
Server di Dominio, demandando a lui la gestione dei permessi delle cartelle e 
sottocartelle.  
È infatti consigliato modificare a priori i permessi del Folder di INFO-OS utilizzando 
l’utente Administrator del DC. 
 
Di seguito la configurazione raccomandata di un Folder condiviso in SMB sotto dominio 
Windows: 

●​ Data → Folders - Virtual disks → [Folder interessato] → Access control 
○​ Impostare “Owner”’ l’administrator del DC e abilitare tutti i suoi Flag in 

“Permissions” 
■​ È anche possibile impostare come “Group” un gruppo del Dominio 

che si desidera possa utilizzare e modificare il Folder, nel nostro 
esempio selezioniamo tutti gli utenti di Dominio con domain users. 

●​ Data → Folders - Virtual disks → [Folder interessato] → SMB share 
○​ Impostare “NTFS ACLs:” su “Yes” 
○​ Impostare “ZFS ACL:” su “Yes” 
○​ Impostare “Permission inheritance:” su “Yes” 
○​ Impostare “Enable ACL inheritance:” su “Yes” 
○​ Impostare il resto delle configurazioni in base ai propri bisogni e salvare 

ed eseguire lo Share del Folder. 
​
La configurazione sopra indicata consente di gestire i permessi del Folder e delle 
sottocartelle tramite Administrator, gli Utenti e Gruppi del dominio usando l’interfaccia 
di Proprietà e Sicurezza di Windows. 
 
N.B.: Se si vuole aggiungere alla lista dei permessi, di un Folder o cartella, ulteriori utenti o 
gruppi del Dominio, è necessario modificare le proprietà di sicurezza tramite un Computer 
facente parte del Dominio stesso. Generalmente, è consigliato l’utilizzo del Server di 
Dominio Administrator stesso. 
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Condivisione di un Folder in NFS 
Per condividere un folder in NFS: 

●​ Data → Folders - Virtual disks → [Folder interessato] → NFS Share 
○​ Cliccare su “+ Host” 
○​ Impostare i parametri di condivisione 
○​ Salvare la condivisione 
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Condivisione di un Virtual disk in iSCSI 
Per condividere un Virtual disk in iSCSI: 

●​ Data → Folders - Virtual disks → [Virtual disk interessato] → SCSI share 

○​ Cliccare su “Share this disk”  

 
 
Una volta condiviso sarà possibile vederne la stringa identificativa IQN e modificarne il 
Portal group andando in: 

●​ Data → Folders - Virtual disks → [Virtual disk interessato] → SCSI share → Main 
porta group 

○​ Cliccare su “Edit this share”  
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Creazione di Snapshot e schedulazioni 
Per eseguire uno snapshot manuale o per creare una schedulazione di snapshot: 

●​ Data → Folders - Virtual disks → [Dataset interessato] → Snapshots 
○​ “Take snapshot now” per Snapshot manuali 
○​ “Schedule snapshots” per schedulazioni di Snapshot 

 
In caso di configurazione con virtualizzazione nativa su versione 4.5 o più recente, vedi 
anche: Creazione e gestione di Snapshot di virtual machine. 

 
Quando si crea uno Snapshot si crea una forma di punto di ripristino. ​
Uno Snapshot comunica al sistema ZFS di non sovrascrivere i dati nei loro blocchi 
originari, questo significa non cancellare o modificare blocchi contenenti dati vecchi ed 
essere quindi in grado in qualsiasi momento di tornare a uno stadio precedente. 
 
Nella fase di creazione di una schedulazione di Snapshot è necessario inserire i 
seguenti parametri: 

1.​ Con quale intervallo eseguire lo Snapshot 
2.​ Quanti snapshot mantenere 

 
Si possono creare più schedulazioni per lo stesso Dataset, ad esempio una 
schedulazione oraria e una giornaliera. 
 
N.B: È bene evitare di creare schedulazioni che coincidano in un determinato orario poiché 
nello stesso momento si andrebbero a generare due Snapshot dello stesso Dataset 
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Vers. 4.5.0.0 - rev. 30 e precedenti 

 

 
Vers. 4.5.0.0 - rev. 31 e successive 
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È possibile visualizzare e modificare tutte le schedulazioni esistenti, sia locali che 
remote, in: 

●​ Data → Scheduled Snapshot 
 

 
Vers. 4.5.0.0 - rev. 30 e precedenti 

 

 
Vers. 4.5.0.0 - rev. 31 e successive 

 
 
N.B.: le schedulazioni gestiscono solamente gli snapshot generati dalle stesse, pertanto in 
caso di modifica o eliminazione e ricreazione di una schedulazione, si dovrà procedere 
all’eventuale cancellazione degli Snapshot “vecchi” (oltre il numero definito in “Keep last”), 
generati dalla schedulazione originale, manualmente.  
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Shadow Copy (versioni precedenti) 
Con INFO-OS è possibile visualizzare gli Snapshot eseguiti del Folder come versioni 
precedenti di Windows.  
 
Per far ciò è necessario condividere il proprio Dataset in SMB (vedi: Condivisione di un 
Folder in SMB) e abilitare la voce “Shadow copy” nelle impostazioni della condivisione. 
 
Così facendo si avrà la possibilità di vedere gli Snapshot tramite le versioni precedenti 
di Windows delle proprietà delle cartelle e sottocartelle. 
Quanto verrà visualizzato sarà in sola lettura, si potrà quindi verificare lo stato dei dati 
ad un dato momento definito dallo snapshot o/e recuperare file e cartelle effettuando 
una copia. 
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N.B.: Si potrebbe riscontrare una discordanza tra l'orario della versione precedente di 
Windows e quello dello Snapshot reale, poiché i server lavorano generalmente in UTC per 
evitare errori di sincronizzazione nei trasferimenti dei dati. L'utilizzo dell'ora locale (ad 
esempio a Roma, Madrid, ecc.) o l'adozione dell'ora legale in alcuni paesi potrebbe causare 
confusione o errori.  
​
Per ovviare a questa problematica, l'interfaccia grafica corregge l'incongruenza per fornire 
all'utente un'informazione coerente con il suo orario. Tuttavia, se si esegue una correzione 
dell'ora e il sistema non è connesso a internet (come spesso accade in questo tipo di 
macchine), l'orario non verrà aggiornato al cambio dell'ora, pertanto attualmente non è 
presente questa correzione artificiale per le Shadow Copy. 
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Errore: Elemento non trovato 
Questo è un errore noto con alcune versioni di Windows che introducono un metodo 
diverso di “file-ID open” non supportato da precedenti implementazioni SMB. 
 
Quando si tenta di ripristinare un file tramite le versioni precedenti di Windows 
eseguendo un comando drag-and-drop o copia-ed-incolla si può, nelle circostanze sopra 
menzionate, riscontrare il seguente errore: 
 

 
 
Per aggirare l’errore si può aprire il file in questione tramite un editor di testo qualsiasi e 
salvarlo con nome – senza modificare l’estensione del file – dentro alla condivisione 
originale (o localmente).  
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Repliche locali e cloni 
Gli Snapshot possono essere replicati per creare una copia locale o remota dei dati, 
oppure clonati per creare un’istanza utilizzabile dei dati senza occupare spazio 
aggiuntivo, almeno fino a quando non viene apportata una modifica, questo perché lo 
Snapshot originale e il Clone condividono lo stesso blocco di dati.  
Essendo le repliche delle vere e proprie copie dei dati, queste possono essere utilizzate 
come Dataset nuovi e indipendenti dagli originali, mentre i cloni fanno riferimento agli 
Snapshot dalla quale sono stati generati e a essi rimangono legati. ​
I Cloni possono essere utilizzati per scopi di sviluppo, test e analisi forense senza 
influire sui dati originali. Più comunemente li si utilizza per verificare se lo Snapshot 
d’origine in questione è utilizzabile per lo scopo desiderato, ad esempio se precedente o 
successivo alla eliminazione di un dato che si vuole recuperare o alla criptazione dei 
dati da un eventuale Cryptolocker. 
 
N.B.: Terminata la sua funzione, il Clone deve essere cancellato! Poiché il Dataset e lo 
Snapshot originali non possono essere cancellati finché il Clone stesso esiste.  
Per questi motivi i Cloni non devono essere usati a lungo termine né messi in produzione. 
 
La creazione di una replica locale o di un clone è possibile tramite: 

●​ Data → Folders - Virtual disks → [Dataset interessato] → Snapshots → 
[Snapshot interessato] 

○​ “Replicate this snapshot” per aprire il menù di replica 
■​ impostare “Destination” su “Local” e indicare il luogo in cui verrà 

creata la cartella con nome assegnato “Name” della replica dello 
Snapshot (consigliamo di impostare la root del pool come 
destinazione) 

○​ “Clone this snapshot” per creare un clone con nome assegnato (il 
clone verrà generato automaticamente all’interno del Folder Clones) 

■​ Una volta generato il Clone, lo si potrà condividere tramite i vari 
protocolli di condivisione di rete come un qualsiasi altro Folder. 

 
N.B.: Per la clonazione di Virtual Machine in un sistema Hyper Converged con 
virtualizzazione nativa e vers. 4.5 vedi: Cloni di una Virtual Machine. 
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Repliche remote (manuali e schedulate) 
Per replicare in remoto è innanzitutto necessario inserire le chiavi di replica della 
macchina principale (denominata Sender) nella secondaria (denominata Receiver) e 
viceversa. 
 
La pagina dalla quale si possono gestire le chiavi di replica è la seguente: 

●​ Data → Replication keys 
○​ Utilizzando il bottone‎  si potrà aggiungere la chiave di una 

macchina che sarà quindi autorizzata a inviare repliche su quella che si 
sta attualmente configurando. 

○​ → Local key: è la chiave della macchina sulla quale si sta lavorando. 
Inserendo questa chiave dentro a un altro Storage si potranno eseguire le 
repliche remote verso di essa. 
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Durante l’inserimento della chiave di replica verranno autocompilati i campi IP address e 
Reference. 
Tali campi non sono necessari al funzionamento delle repliche, ma utili alla rapida 
identificazione del sistema a cui la chiave fa riferimento, pertanto sono modificabili a 
piacimento.  
 
È inoltre fondamentale che i due sistemi possano comunicare tra loro tramite IP e porta 
SSH. 
È possibile verificare la corretta comunicazione fra i 2 sistemi attraverso il bottone Test 
connection. 
 
Una volta associate tramite la condivisione delle chiavi di replica, e accertatisi della 
corretta comunicazione, si potranno eseguire le repliche remote tra i due sistemi. 
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Creazione di una Replica remota di un singolo Snapshot 
La creazione di una Replica remota di un singolo Snapshot è possibile tramite: 

●​ Data → Folders - Virtual disks → [Dataset interessato] → Snapshots → 
[Snapshot interessato] 

○​ “Replicate this snapshot” per aprire il menù di replica 
■​ impostare “Destination” su “Remote”. 
■​ Indicare l’IP della macchina remota. 
■​ Indicare la destinazione in cui verrà creata la cartella con nome 

assegnato “Name” della replica dello Snapshot (raccomandiamo di 
impostare la destinazione come la root del Pool remoto). 

 
Una volta avviata la Replica sarà possibile monitorarla tramite la pagina di Replication 
Status. 
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Creazione di una schedulazione di Replica remota 
La creazione di una schedulazione remota, invece, è possibile tramite: 

●​ Data → Folders - Virtual disks → [Dataset interessato] → Snapshots → Schedule 
snapshots → Add new schedule snapshot: 

 
Qui andranno compilati i campi come segue: 

●​ Abilitare Replicate, impostare “Destination” su “Remote”. 
●​ Indicare l’IP della macchina remota. 
●​ Indicare la destinazione in cui verrà creata la cartella con nome assegnato 

“Name” della replica dello Snapshot (raccomandiamo di impostare la 
destinazione come la root del Pool remoto). 

●​ Scegliere quanti Snapshots mantenere sulla macchina remota 
●​ L’ultima configurazione riguarda la sincronizzazione manuale o automatica, la 

quale definisce il comportamento della replica nel caso di non corrispondenza 
fra snapshot su sistema sender e receiver (remoto). ​
 
Nello specifico: durante una replica, viene verificata la corrispondenza fra 
snapshot locali e remoti e se fra i due esiste sincronia lo snapshot viene replicato 
con successo. Ma, ad esempio, nel caso il sistema remoto fosse rimasto spento 
o la replica disabilitata per un periodo di tempo, gli snapshot remoti potrebbero 
risultare obsoleti rispetto a quelli locali (non corrispondenti, asincroni). 

○​ Nel caso in cui la sincronizzazione sia impostata su manuale (Manual), la 
replica si fermerà. Per procedere sarà quindi necessario cancellare gli 
snapshot sul folder di destinazione remota, consentendo al sistema 
principale di eseguire un full send, ri-sincronizzandoli. 

○​ Nel caso in cui la sincronizzazione sia impostata su automatico (Auto) 
(opzione consigliata), l’operazione sopra descritta verrà effettuata in 
maniera automatica dal sistema principale in fase di replica. 

 
Per replicare in remoto una schedulazione di Snapshot già esistente è sufficiente 
modificare la stessa tramite:  

●​ Data → Folders - Virtual disks → [Dataset interessato] → Snapshots → Schedule 

snapshots → [Schedulazione snapshot interessata]  
Oppure da: 

●​ Data → Scheduled Snapshots → [Dataset interessato] → [Schedulazione 

snapshot interessata]  
 
E abilitare Replicate seguendo le indicazioni sopra riportate. 
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A partire da Vers. 4.5.0.0 - rev. 31 di INFO-OS è possibile schedulare una replica primaria 
e secondaria, permettendo quindi di replicare lo stesso Dataset due volte con il 
medesimo Snapshot. 
 
Alla modifica della schedulazione di uno Snapshot si potrà quindi vedere e gestire 
l’opzione di una “Main Replica” ed una “Secondary Replica”.  
 
Queste potranno essere inviate sul medesimo sistema, su di uno differente o anche in 
locale indipendentemente l’una dall’altra. 
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Status Replicazione 
Nel sistema principale è possibile verificare il progresso e stato di una replica tramite: 

●​ Data → Replication status: 
 
Qui verrano mostrate tutte le Repliche manuali e schedulate attive e si potrà verificare 
l’avanzamento ed esito del trasferimento della replica tra il sistema primario e 
secondario e si potrà diagnosticare, tramite il log allegato, la causa di eventuali blocchi 
o errori. 
 
Nell’esempio di fallimento Replica sotto-riportato, la macchina secondaria receiver non 
ha spazio sufficiente per la scrittura della Replica. 
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Restore di uno Snapshot 
Il restore di uno Snapshot implica il ritorno, in modo definitivo, del Dataset a uno stato 
“precedente” definito dal dato Snapshot. ​
Tale opzione viene usata solitamente in casi di emergenza quali ad esempio 
Cryptolocker, perdita o corruzione di dati, o in qualsiasi situazione in cui il dataset 
attuale risulti inutilizzabile, quindi non rimediabile tramite l’utilizzo di repliche e cloni.  
 
Per eseguire il restore di uno snapshot: 

●​ Data → Folders - Virtual disks → [Dataset interessato] → Snapshots → 
[Snapshot interessato] → Restore this snapshot  

 
N.B.: Quando si esegue il restore di uno Snapshot, tutti gli Snapshot successivi a esso, 
cioè più recenti, verranno eliminati. 
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Fermo macchina principale e messa in produzione 
macchina secondaria 
Di seguito è descritta la procedura ‘tipo’ da adottare nel seguente scenario: 

●​ Si dispone di 2 sistemi INFO-OS. 
●​ Il sistema primario è configurato per replicare snapshot remoti sul sistema 

secondario. 
●​ Il sistema primario deve subire un consistente fermo macchina per qualsivoglia 

ragione. 
 
Nel caso di fermo macchina programmato, si potrà effettuare uno snapshot manuale 
remoto dei folder immediatamente prima del fermo, in modo da poter riportare online il 
sistema secondario senza alcuna perdita. ​
Nel caso in cui il fermo macchina sia imprevisto, il sistema secondario sarà portato 
online utilizzando l’ultimo snapshot ricevuto dei vari folder replicati: 

●​ Spegnere eventuali VM che fanno riferimento a datastore presenti sul sistema 
primario. 

●​ Il sistema primario dovrà essere spento, o comunque dovranno essere fermate le 
schedulazioni remote verso il sistema secondario. 

○​ Questa operazione rende stabili i folder sul sistema secondario, poiché 
non vengono più modificati dagli snapshot remoti da parte del sistema 
primario. 

●​ Si potranno quindi abilitare le condivisioni sul sistema secondario, utilizzandoli 
per il periodo necessario. 

○​ È fondamentale che durante questo periodo, il sistema primario rimanga 
offline, per evitare problemi di sorta, quali ad esempio: 

■​ Invii snapshot remoti al secondario che attualmente è in 
produzione. 

■​ Accensioni erronee di VM su primario mentre la stessa è accesa e 
in uso su secondario. 

■​ Conflitti di IP. 
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Terminato il periodo di fermo del sistema primario, si dovranno iniziare le procedure per 
ripristinare la situazione originale, sostanzialmente identiche a quelle per passare da 
primario a secondario, ma con alcune accortezze. 

●​ Prima di riportare online il sistema primario, fare attenzione che le schedulazioni 
remote da primario a secondario non siano attive, per evitare di andare a 
sovrascrivere gli snapshot recenti del secondario con snapshot del primario 
precedenti al fermo. 

●​ Si potrà quindi procedere a un nuovo fermo, questa volta delle VM o dei folder 
condivisi dal sistema secondario. 

●​ Si potrà effettuare uno snapshot manuale remoto da secondario verso primario, 
utilizzando come destinazione e nome di ogni snapshot il relativo folder di 
origine sul sistema primario. 

○​ In questo modo i folder sul sistema primario verranno aggiornati all’ultima 
modifica effettuata durante il periodo di lavoro su secondario. 

●​ Il sistema primario sarà quindi pronto per essere riportato online, e una volta 
verificato il corretto funzionamento si potranno ripristinare le schedulazioni 
remote da primario verso secondario. 
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Connessione a un gruppo di continuità (UPS) 
Il servizio si attiva e si configura dalla pagina: 

●​ Services → UPS 

 
 
Di seguito un esempio di configurazione: 
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Quando il servizio è attivo appare un pulsante nella barra in alto, tramite il quale è 
possibile accedere a una pagina di visualizzazione dello stato dell'UPS. 
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Virtualizzazione nativa (Hypervisor) su Vers. 3 

Attivazione del servizio di Virtualizzazione 
Per attivare le funzioni di virtualizzazione tramite VirtualBox, nativa di INFO-OS, è 
necessaria la licenza Virtualization. Per abilitare la virtualizzazione: 

●​ Virtualization → [Pool su cui virtualizzare] → Enable VirtualBox → Save & Restart 
 
Si potrà quindi accedere alla pagina di VirtualBox attraverso il relativo pulsante: 
 

 
 
Le credenziali di accesso impostate di default per la pagina di VirtualBox sono:​
User: admin 
Password: admin 
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Creazione di una VM su VirtualBox 
Agendo sul tasto New sarà possibile creare una VM seguendo i seguenti passaggi: 

●​ Assegnare Nome, tipo e versione del sistema operativo. 
●​ Selezionare la quantità di RAM che si desidera dedicare alla VM. 
●​ Proseguire con le impostazioni del disco. 
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Una volta creata è possibile modificare i parametri più specifici selezionando la virtual 
machine e cliccando “Settings”, di seguito alcune indicazioni sulla loro configurazione: 

●​ System → Boot Order → Hard Disk e Optical per primi. 
●​ Display → Remote Display 

○​ Server Port → Assegnare una porta fissa compresa fra 9000 e 9100, non 
utilizzata da altre VM 

○​ VNC Password → selezionare una password per l’accesso tramite VNC. 
●​ Storage 

○​ Per puntare una ISO di installazione tramite unità optical: 
■​ CD/DVD Drive → Navigare → Choose a virtual optical disk file → 

mnt/[pool]/folder (es. Repository) → file.iso 
●​ Network → Attached to →  

○​ Bridged Adapter - se si vuole che la virtual machine abbia accesso alla 
rete. 

 
N.B.: i virtual disk assegnati alle macchine virtuali non potranno essere espansi una volta 
creati. 
 
Si potrà anche gestire il suo relativo Folder per la creazione di snapshot, repliche, cloni e 
per la configurazione di compressione ed utilizzo Cache write, tramite: 

●​ Data → Folders - Virtual disks → [Pool] → VBox → [Folder VM] 
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Collegamento al desktop virtuale 
Per eseguire il collegamento al desktop virtuale è necessario configurare nelle 
impostazioni della virtual machine: 

●​ Display → Remote Display 
○​ Server Port → una porta fissa compresa fra 9000 e 9100, non utilizzata da 

altre VM 
○​ VNC Password → selezionare una password per l’accesso tramite VNC 

 
Dopodiché ci si potrà collegare con un client VNC utilizzando l’IP, la porta e la password 
specificate oppure direttamente da INFO-OS tramite: 

●​ Virtualization → noVnc 
 
Si aprirà una nuova pagina nel browser con noVNC, e si specificherà la porta tramite: 

●​ Ingranaggio impostazioni → Advanced → WebSocket 
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Una volta installata la Virtual Machine è fortemente raccomandata l’installazione dei 
VBoxGuestAdditions, che possono essere scaricati al seguente link: 
https://download.virtualbox.org/virtualbox/6.1.10/VBoxGuestAdditions_6.1.10.iso 
 
Dopo aver effettuato il primo setup, raccomandiamo di abilitare ed utilizzare il desktop 
remoto.  
​
Questo perché se si spegne la virtual machine mentre si è ancora collegati tramite VNC, 
è possibile che questa vada in stato “Stopping” e non risponda più a comandi di 
spegnimento/accensione.  
 
In questo stato, sarà necessario eseguire una delle seguenti operazioni: 

●​ Tramite Virtualization, cliccare Save & Restart. 
●​ Tramite Virtualization, disabilitare la virtualizzazione, salvare e abilitarla salvando 

nuovamente. 
●​ Riavviare l’host INFO-OS. 
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Gestione orologio, impostazioni per il Timekeeping 
Il Timekeeping gestisce la coincidenza dell’orologio della virtual machine con quello 
dell’host/reale e in alcune configurazioni può risultare complicato da controllare.  
 
Per esempio, se gli interrupt del timer sono virtualizzati, il gestore degli interrupt in una 
particolare macchina virtuale può essere ritardato quando la macchina fisica è 
occupata, ad esempio con altre macchine virtuali, e la volta successiva, quando l'host 
fisico è inattivo, diversi IRQ potrebbero essere gestiti in blocco per recuperare il tempo 
corrente. 
 
I sistemi operativi sono già progettati tenendo conto di questo aspetto e in genere 
eseguono software per correggere questa deriva, come NTP o w32time. 
 
Di fatto, le prestazioni della sincronizzazione temporale in una macchina virtuale 
dipendono: 

●​ dal tipo e dalla versione del sistema operativo in esecuzione nella macchina 
virtuale 

●​ dal tipo e dalla versione del software dell'hypervisor in esecuzione sulla 
macchina fisica, e quindi dalla programmazione dei tick del timer per le 
macchine virtuali 

●​ e dalle risorse disponibili al sistema e macchine virtuali. 
 
VirtualBox, come altri hypervisor, fornisce meccanismi propri per disciplinare l'ora in 
modo più o meno accurato tramite l'utilizzo dei propri Tools (GuestAdditions), ma in 
alcuni casi è suggerito installare software come il demone NTP nelle macchine virtuali. 
 
Non esiste quindi una configurazione predefinita che funzioni in tutti i casi e situazioni, 
se si dovesse riscontrare un “time drift” (differenza tra orologio/passaggio del tempo 
virtuale e reale) tale da avere un impatto negativo sui servizi/applicativi della virtual 
machine, sarà necessario provare le diverse configurazioni, tra auto-gestione con NTP e 
impostazioni della virtual machine su VirtualBox allo scopo di risolvere. 
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Di seguito le impostazioni che hanno impatto sul Timekeeping: 
●​ Settings Virtual Machine → System → Acceleration → Paravirtualization 

Interface →  
○​ Impostare su None 

●​ Settings Virtual Machine → System →  Motherboard → 
○​ Hardware Clock in UTC Time 
○​ Disable host time sync 
○​ HPET (high precision event timer) 
○​ Chipset 

 
N.B.: Alcune di queste impostazioni, più in particolare le seguenti, possono essere 
dannose al funzionamento della VM e possono ridurre le prestazioni: 

●​ HPET (high precision event timer) 
●​ Paravirtualization Interface 
●​ Chipset​

 
Consigliamo, come sempre, di assicurarsi di disporre di Snapshot ed eventuali backup 
prima di effettuare prove di questo tipo su macchine in produzione. 
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Importazione di una Virtual Machine esterna 

Import di Virtual Machine completa esportata in .ovf o .ova 
Il procedimento consigliato per importare una Virtual Machine e successivamente 
assegnarle il Dataset (per la gestione degli snapshot):​
 

1.​ copiare i/il file della vm in un Folder condiviso da INFO-OS 
2.​ su INFO-OS aprire l'interfaccia di VirtualBox (da Virtualization > VirtualBox) 
3.​ cliccare su File → Import Appliance... 

○​ tramite l'apposito bottone a forma di cartella con freccia, navigare al 
Folder nella quale si è copiato i/il file 

○​ selezionare il file con estensione .ovf (o .ova in base al tipo di vm) e 
cliccare Next 

○​ verificare le informazioni e opzionalmente selezionare la casella 
"Reinitialize the MAC Address of all network cards" 

○​ cliccare Import​
 

4.​ la VM a questo punto dovrebbe essere stata importata ed essere disponibile tra 
le opzioni, ora possiamo procedere ad assegnarle un Dataset:​
 

5.​ creare una nuova vm tramite il bottone "New" 
○​ chiamarla in un modo diverso dalla vm originale (ad esempio con un "2" 

alla fine del nome) 
○​ assegnarle tutte le medesime caratteristiche/impostazioni della vm 

originale 
○​ durante la fase di creazione alla scelta "Hard disk" selezionare "Do not add 

a virtual hard disk" 
○​ Create​

 
6.​ su INFO-OS verificare che il Folder della nuova vm appena creata sia stato 

correttamente creato sotto a [Pool] → VBox, tramite Data → Folders / Virtual 
Disks 
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7.​ su virtual box andare su File → Virtual Media Manager 
○​ selezionare il disco della vm originale e fare "Copy" 

1.​ cliccare "Expert Mode" 
2.​ alla voce "New hard disk to create" cliccare il simbolo della cartella 

con freccia verde (che si trova a destra) per determinare dove 
creare la copia 

■​ sarà necessario selezionare: mnt → [Pool] → VBox → [nuova 
vm] e poi cliccare Ok 

3.​ Copy​
 

8.​ una volta finito il processo di copia, andare nelle impostazioni "Storage" della 
nuova vm 

○​ aggiungere un nuovo disco con l'apposito bottone 
○​ selezionare "Choose existing disk" 
○​ selezionare il disco copiato che si trova all'interno del Folder della nuova 

vm stessa (vedi punto 7.1.2)​
 

9.​ a questo punto si può procedere all'avvio della nuova vm e rimozione della 
vecchia (prima verificare che tutto funzioni correttamente) 

○​ al primo avvio è possibile che venga richiesto cosa usare come disco di 
Boot, sarà sufficiente selezionare il disco copiato/della nuova vm 
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Import di un disco virtuale 
Se si dispone di un disco virtuale anziché una virtual machine intera, la procedura è 
simile: 

1.​ copiare i/il file della vm in un Folder condiviso da INFO-OS 
2.​ su INFO-OS aprire l'interfaccia di VirtualBox (da Virtualization → VirtualBox) 
3.​ cliccare su File → Virtual Media Manager 

○​ cliccare Add 
○​ navigare al Folder nella quale si è copiato i/il file: mnt → [Pool] → [Folder]  
○​ selezionare il file del disco virtuale e cliccare Ok​

 
4.​ creare una nuova vm tramite il bottone "New" 

○​ durante la fase di creazione alla scelta "Hard disk" selezionare "Do not add 
a virtual hard disk" 

○​ Create​
 

5.​ tornare su File → Virtual Media Manager 
○​ selezionare il disco e fare "Copy" 

1.​ cliccare "Expert Mode" 
2.​ alla voce "New hard disk to create" cliccare il simbolo della cartella 

con freccia verde (che si trova a destra) per determinare dove 
creare la copia 

3.​ sarà necessario selezionare: mnt → [Pool] → VBox → [nuova vm] e 
poi cliccare Ok 

4.​ Copy​
 

6.​ una volta finito il processo di copia, andare nelle impostazioni "Storage" della 
nuova vm 

○​ aggiungere un nuovo disco con l'apposito bottone 
○​ selezionare "Choose existing disk" 
○​ selezionare il disco copiato che si trova all'interno del Folder della nuova 

vm stessa (vedi punto 5.1.2-3)​
 

7.​ a questo punto si può procedere all'avvio della vm e rimozione del disco "vecchio" 
nel Folder usato come appoggio (prima verificare che tutto funzioni 
correttamente): 

○​ al primo avvio è possibile che venga richiesto cosa usare come disco di 
Boot, sarà sufficiente selezionare il disco copiato/della nuova vm  
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Esportazione ed estrazione di una Virtual Machine 
Di seguito la procedura per eseguire l'esportazione e 'raccolta' di una Virtual Machine da 
Vbox, è fondamentale che tutti gli step vengano eseguiti ed in ordine: 
 
Su INFO-OS creare un nuovo Folder: 

●​ Data → Folders - Virtual disks → [Pool o Folder interessato] → +Folder​
 

Modificare i parametri di Access control del Folder: 
●​ Data → Folders - Virtual disks → [Folder interessato] → Access control → Edit 

this permission 
○​ Abilitare tutti i flag di permessi, anche a Group e Others e poi salvare​

 
Su VirtualBox, esportare la Virtual Machine: 

●​ File → Export Appliance... → [Virtual Machine interessata] → Next 
○​ → Selezionare destinazione, cioè il Folder appena creato lato INFO-OS, 

dovrebbe essere così formattato: 
■​ /mnt/[Nome Pool]/[Folder creato]/[VirtualMachine.ova] 

○​ → Abilitare se si desidera la creazione del Manifest File → Next 
○​ → Verificare le informazioni → Export​

 
Una volta finita l'esportazione, tornare su INFO-OS e condividere in NFS il Folder 
contenente il file .ova: 

●​ Data → Folders - Virtual disks → [Folder interessato] → NFS share 
○​ Cliccare su “+ Host” 
○​ Impostare i parametri di condivisione, in particolare specificare: 

■​ All users as root: Yes 
○​ Salvare la condivisione 

 
Su un Client Windows, abilitare: Servizi per NFS e Client per NFS tramite l'utility di 
Windows: Funzionalità di Windows. 
 
In seguito aprire la console CMD ed eseguire il seguente comando per collegare il 
Folder NFS: 

●​ mount -o nolock \\[IP INFO-OS]\[percorso Folder NFS] {NomeDispositivo | *} 
○​ Esempio: mount -o nolock \\192.168.1.10\mnt\vol1\test Y: 
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Una volta collegato, aprire la cartella, verificare la presenza del file .ova della Virtual 
Machine esportata e modificarne le proprietà: 

●​ Proprietà → Attributi NFS: 
○​ Abilitare tutti i Flag di Autorizzazioni file per: Proprietario, Gruppo ed Altro 
○​ Impostare: Proprietario (UID): 0 
○​ Applicare 

 
A questo punto si potrà copiare o spostare il file della Virtual Machine. 
 
Una volta finita l'operazione consigliamo di disconnettere l'unità da Windows, rimuovere 
lo share NFS lato INFO-OS ed eventualmente cancellare il Folder in questione.  
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Virtualizzazione nativa (Hypervisor) su Vers. 4.5+ 

Setup iniziale 
Per attivare le funzioni di virtualizzazione nativa di INFO-OS, è innanzitutto necessaria la 
licenza Virtualization.  
 
Dopo aver creato il POOL, si potrà attivare il servizio di virtualizzazione navigando alla 
pagina “Virtualization” dove si imposterà su “Enable” la virtualizzazione indicando 
tramite il menu a tendina il POOL utilizzato dalle virtual machine e infine si cliccherà su 
“Save & Restart”. 
Una volta eseguita questa operazione si avrà accesso al menu di virtualizzazione. 
 

 

 
 
Per la corretta gestione dei file necessari alla virtualizzazione, quali immagini .ISO di 
sistemi operativi, driver, virtualbox guest additions, dischi e macchine virtuali da 
importare, è consigliato creare un Folder condiviso all’interno del POOL dove questi 
possano essere inseriti, vedi Creazione di un Dataset (Folder e Virtual Disks).  
Di norma a questo Folder viene assegnato il nome di Repository. 
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Creazione di una Virtual Machine 
Si può procedere alla creazione della virtual machine tramite la pagina: 

●​ Virtualization → Machine▼ →  New 

 
 
Qui si aprirà un nuovo menu nella quale sarà possibile specificare: 

●​ Name: nome della virtual machine 
●​ Path: la destinazione dove verrà creato il Folder della virtual machine (di default 

impostato su /mnt/[POOL]/VBox) 
●​ Operating System Type: il tipo di sistema operativo della virtual machine che 

assieme alla voce Operating System Version definirà parte dell’hardware virtuale 
e relativi driver. 

●​ Operating System Version: la versione del sistema operativo della virtual 
machine che assieme alla voce Operating System Type definirà parte 
dell’hardware virtuale e relativi driver. 

●​ Memory size (RAM): definisce la quantità di RAM che si assegna alla virtual 
machine. 

●​ Hard disk: 
○​ Do not add a virtual hard disk: non verrà assegnato alcun disco virtuale 

alla virtual machine, utile in quelle situazioni dove si vuole predisporre una 
virtual machine per una conseguente assegnazione di disco preesistente. 

○​ Create a virtual hard disk now: creerà un disco virtuale nel momento della 
creazione della virtual machine. 

○​ Use an existing virtual hard disk: assegnerà un disco virtuale preesistente 
(selezionabile dall’apposita tendina) alla virtual machine, utile per quando 
si importano dischi virtuali, per esempio dischi di macchine fisiche 
trasformati in virtuale. 

 
Se si ha selezionato l’opzione di creazione di un nuovo disco virtuale, cliccando Next si 
proseguirà alla pagina che permette di configurare tale disco. 
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Quando si sarà creata la virtual machine, si potranno modificare ulteriori impostazioni 
selezionandola dall’elenco visibile in “Machine” e modificando i vari parametri che si 
trovano in “Details”. 
 
In generale, la configurazione hardware della virtual machine dipende dalle prestazioni 
che si vogliono ottenere e dai limiti imposti dall’hardware fisico. 
​
Le principali voci che vengono modificate sono: 

1.​ La quantità di processori virtuali assegnati: 
○​ Details → General info →  Edit → Processors 

2.​ L’ordine di Boot in:  
○​ Details → General info →  Advanced Options → Motherboard▼ → Boot 

Order 
■​ Dove al primo posto (modificabile utilizzando le freccette) viene 

posto il disco (Disk) e al secondo il CD/DVD per l’installazione e 
dove spesso l’opzione di avvio dal Floppy disk viene disabilitata. 

3.​ Il collegamento VNC tramite: 
○​ Details → Display →  Edit 

■​ Qui si potrà specificare una porta per il collegamento remoto 
(Remote Display Port) e la relativa password (Remote Display 
Password). 

4.​ La scheda di rete: 
○​ Details → Networks→  Network Interface: 1  

■​ Generalmente la voce NIC sotto a “Network Interface Card” viene 
impostata su “Bridged Adapter” per permettere alla virtual machine 
di uscire con un IP proprio e usufruire direttamente della scheda di 
rete fisica.​
N.B.: fare riferimento a Lentezza scheda di rete se si riscontrano 
problemi di performance dopo l’abilitazione di “Bridged Adapter”. 

 
Modifiche al numero di processori virtuali, quantità di RAM assegnati alla virtual 
machine e tipologia di sistema operativo installati possono essere effettuate tramite la 
voce:  

●​ Details → General info →  Edit 
 
Una volta che la virtual machine è stata configurata come meglio si preferisce, e una 
volta assegnato un disco contenente una installazione o un cd/dvd con file .ISO per 
eseguirne una nuova, si potrà avviare con il specifico bottone Power ᐅ e collegarsi al 
desktop virtuale tramite un qualsiasi Client VNC. 
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Windows Server 2025 - configurazione per l’installazione 
Per il supporto all’installazione di Windows Server 2025, è necessario attivare alcuni 
parametri specifici per il suo corretto funzionamento: 

1.​ Come base della vm: 
a.​ Operating System Type: Microsoft Windows 
b.​ Operating System Version: Windows 2019 (64bit) 

2.​ Dopo la creazione e prima del primo avvio: 
a.​ Details → General info → Advanced  

i.​ Motherboard → High Precision Event Timer (HPET) → ON 
ii.​ Acceleration → Paravirtualization Interface → HyperV 
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Connessione al Desktop virtuale 
Per configurare la connessione al Desktop virtuale tramite client VNC dirigersi su: 

●​ Virtualization → Machine▼ → [VM interessata] → Details → Display 
Qui abilitando la voce “VRD” si attiverà la funzione di desktop virtuale che si potrà 
configurare tramite il bottone “Edit”. 
Di default il range consentito per la porta di collegamento (“Remote Display Port”) varia 
da 9001 a 9099. 
Generalmente la prima virtual machine creata impiegherà automaticamente la porta 
9000 e ad ogni virtual machine successiva verrà assegnata una porta in ordine 
progressivo, per esempio la seconda virtual machine avrà porta 9001, la terza 9002, etc. 
 
La password di default per il collegamento è “info-os” ed è possibile collegarsi con un 
qualsiasi client VNC specificando l’IP di INFO-OS e la porta assegnata alla virtual 
machine. Se il client con la quale ci si collega è correttamente configurato per l’apertura 
di link, è possibile cliccare sulla preview della virtual machine per aprire direttamente la 
connessione al desktop remoto. 

 

Caricamento di file .ISO per l’installazione di Virtual Machine 
Una volta preparata la virtual machine le si potrà assegnare la .ISO dalla quale eseguire 
il BOOT per l’installazione tramite: 

●​ Virtualization → Media Manager▼ → Add cd/dvd 
 
Si aprirà quindi una pagina dove poter selezionare il file .ISO dall’interno del POOL (file 
che dovrebbe essere caricato dentro al Folder Repository come indicato nel Setup 
iniziale) e dove poter specificare la VM alla quale associare tale .ISO e con quale 
controller (generalmente IDE o SATA). Una volta fatto si potrà proseguire cliccando “Add 
optical drive”. Così facendo sarà stato aggiunto un lettore cd/dvd virtuale con all’interno 
la .ISO del sistema operativo che si vuole installare alla virtual machine selezionata. 
 
N.B.: Alla selezione della .ISO, file con parentesi quadre[ ] nel nome non saranno accettati. 
N.B.2: Al seguente link i driver/VBoxGuestAdditions raccomandati:​
https://download.virtualbox.org/virtualbox/6.1.10/VBoxGuestAdditions_6.1.10.iso 
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Configurazione di rete di una vm 
Tramite la virtualizzazione nativa basata su virtualbox si possono configurare diverse 
tipologie di modalità network per le virtual machine tramite la pagina:: 

●​ Virtualization → Machine▼ → [vm in questione] → Details → Networks → Edit → 
[Scheda di rete interessata] → Edit →  Network Interface Card  

Ogni scheda di rete virtuale assegnata ad una vm, può essere indipendentemente 
configurata come si preferisce. 
 
Di seguito le tipologie ed il loro funzionamento: 
 
Not Attached 
Questa opzione assegna una scheda di rete virtuale alla macchina virtuale, ma la 
connessione di rete è assente, come quando si scollega il cavo di rete Ethernet quando 
si utilizza una scheda di rete fisica. Questa modalità può essere utile per test. Ad 
esempio, è possibile attivare questa modalità di rete per un breve periodo per emulare lo 
scollegamento del cavo.  
 
Anziché utilizzare la modalità di rete “Not Attached” è anche possibile utilizzare 
qualsiasi altra tipologia disattivando l’opzione “Cable” selezionando “Disconnected”. 
 

 
 

109 



NAT​  
Questa modalità di rete è attivata di default nelle schede di rete virtuali. Il sistema 
operativo guest della vm accede agli host di una LAN utilizzando un dispositivo NAT 
(Network Address Translation) virtuale. Le reti esterne, compreso Internet, sono quindi 
accessibili al sistema operativo guest. Tuttavia, la macchina guest non è accessibile da 
una macchina host o da altre macchine della rete quando si utilizza la modalità NAT. 
Questa modalità di rete predefinita è sufficiente per gli utenti che desiderano utilizzare 
una macchina virtuale solo per l'accesso a Internet, ad esempio. 
 
L'indirizzo IP della scheda di rete della macchina virtuale viene ottenuto tramite DHCP e 
gli indirizzi IP della rete utilizzati in questa modalità di rete non possono essere 
modificati nella GUI. VirtualBox ha un server DHCP e un motore NAT integrati. 
 
Se si configurano gli adattatori di rete di due o più macchine virtuali per utilizzare la 
modalità NAT, ogni macchina virtuale otterrà l'indirizzo IP 10.0.2.15 nella propria rete 
isolata dietro un dispositivo NAT virtuale privato. Il gateway predefinito per ogni VM è 
10.0.2.2. Vedi schema di seguito per dettagli. 
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Bridged Adapter 
Questa modalità viene utilizzata per collegare la scheda di rete virtuale di una vm a una 
scheda di rete fisica (o VLAN, LAN aggregata, etc…) dell’host INFO-OS. 
La NIC virtuale utilizza quindi l’interfaccia fisica dell’host per ottenere una connessione 
di rete e i pacchetti di rete vengono inviati e ricevuti direttamente da/dalla virtual 
machine senza instradamenti aggiuntivi.  
 
Virtual machine che devono poter essere completamente accessibili da una rete locale 
fisica dovrebbero utilizzare questa modalità essendo possibile accedere alla vm dal 
sistema host e da altri sistemi e vm collegati alla stessa rete fisica. 
 
Tramite la tendina è possibile selezionare quale scheda di rete fisica utilizzare e 
associare alla NIC virtuale. Così come impostare alcuni parametri, in particolare quello 
che definisce la gestione dei pacchetti denominato Promiscuous Mode. 
 
Per dettagli vedi: Utilizzare una scheda di rete fisica alternativa per la vm e Uso di tap e 
bridge per macchine virtuali. 
Per dettagli riguardo il driver virtuale consigliato vedi: Lentezza scheda di rete. 
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Internal Network 
Le macchine virtuali con questa modalità attiva, sono collegate ad una rete virtuale 
isolata, che permette la comunicazione solo tra vm dello stesso host INFO-OS, non 
consentendogli di raggiungere né essere raggiunte l’Host o altri sistemi della rete locale. 

 
Tecnicamente questa opzione consente di modellare e controllare interi network 
virtuali. Per esempio, è possibile creare diverse vm, nel nostro esempio tre, ognuna delle 
quali ha un NIC impostato in modalità Internal Network con un loro subnet dedicato. 
Una di queste vm (VM1) dispone anche di una seconda scheda di rete virtuale 
configurata in modalità NAT o Bridged Adapter.  
 
Configurando questa vm come router, è possibile permettere alle VM2 e VM3 di 
accedere alla rete esterna impostando come Gateway: l’IP di VM1. 
È quindi possibile rendere VM1 un firewall per le altre vm isolando e proteggendo in 
questo modo il traffico. 
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Host Only Adapter 
In questa modalità le Virtual Machine possono comunicare solamente con l’Host 
INFO-OS e con altre Virtual Machine con NIC impostate in “Host Only Adapter”. 

 
 
È possibile configurare diversi Switch Host Only da assegnare poi alle schede di rete 
virtuali. La gestione e creazioni di questi Switch viene effettuata da: 

●​ Virtualization → Network▼ → List Switch Host Only 
●​ Virtualization → Network▼ → Create Switch Host Only 

 
Andando poi nel Edit  degli Switch creati si potranno 
configurare i vari parametri, tra cui l’IP del gateway, la subnet e 
la presenza o meno di DHCP Server. 

 
Tramite la gestione delle interfacce di rete, LAN Ethernet, si potrà selezionare e 
aggiungere su INFO-OS una (o più) scheda di rete posta all’interno del suddetto Switch 
Host Only per comunicare con le relative VM contenute in esso. 
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Nat Network 
Questa modalità è simile alla modalità NAT utilizzata per configurare un router. Se si 
utilizza la modalità NAT Network per più macchine virtuali, queste possono comunicare 
tra loro attraverso la rete. Le macchine virtuali possono accedere ad altri host nella rete 
fisica e possono accedere a reti esterne, compreso Internet. Le macchine di reti esterne 
e quelle di una rete fisica a cui è connessa la macchina host non possono accedere alle 
macchine virtuali configurate per la modalità Rete NAT e non è possibile accedere alla 
macchina guest dalla macchina host quando si utilizza la modalità NAT Network. Un 
router NAT integrato utilizza un controller di interfaccia di rete fisico dell’Host INFO-OS 
come interfaccia di rete esterna (come nel caso della modalità NAT). 

 
Per utilizzare questa modalità è necessario creare Switch NAT così da poterli 
selezionare nel menù della configurazione della NIC della vm: “Select NAT Switch”: 

●​ Virtualization → Network▼ → Create Switch NAT 
 
Al momento della creazione si possono configurare i parametri e, successivamente, è 
possibile modificarli tramite:  

●​ Virtualization → Network▼ → List Switch NAT → [Switch interessato] → Edit  
 
N.B.: Il Port Forwarding è attualmente disabilitato e non funzionante 
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Utilizzare una scheda di rete alternativa per la vm 
Se si vuole far uscire il traffico di rete di una vm da una scheda di rete fisica che non sia 
la principale, è innanzitutto necessario attivare una seconda scheda di rete come 
indicato nella sezione LAN Ethernet. 
 
Una volta attivata, tale Interfaccia si potrà assegnare alla vm dalla pagina:  

●​ Virtualization → Machine▼ → [vm in questione] → Details → Networks → 
[Network Interface interessata]  

 
Dalle impostazioni dell'interfaccia che si vuole modificare, si potrà mettere la voce "NIC" 
in "Bridged Adapter" e successivamente cambiare la voce "Select Adapter > Interface" 
impostando dalla tendina la scheda di rete fisica (o VLAN) che si vuole usare per la vm. 
 

 
 
N.B.: non ha importanza quale IP sia assegnato a INFO-OS su tale scheda di rete, in quanto 
l'uso della scheda da parte di esso e da parte della vm sono "separati". 
La vm e INFO-OS potrebbero essere su classi di IP differenti senza incontrare alcun 
problema. 
 
N.B.2: l’uso della scheda di rete fisica associata a quella virtuale quando si seleziona la 
modalità “Bridged Adapter”, non è esclusivo. Più virtual machine possono quindi utilizzare 
la medesima NIC fisica in questa modalità. 
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Uso di tap e bridge per macchine virtuali 
In alcune circostanze potrebbe essere utile o necessario utilizzare delle schede virtuali 
TAP poste all’interno di un bridge da assegnare a macchine virtuali. Il loro uso in ambito 
di virtualizzazione può aiutare in caso di problemi firmware della scheda di rete fisica 
sottostante e in altre casistiche può migliorare le performance. 
 
Un bridge è un interfaccia virtuale che agisce come uno switch Ethernet software. 
Consente di collegare più interfacce di rete (fisiche o virtuali) tra loro, facendo passare i 
pacchetti da una all'altra in base agli indirizzi MAC, come se fossero collegate a uno 
switch fisico. È utile per creare reti locali virtuali (LAN) all'interno del sistema, 
specialmente quando si vogliono collegare macchine virtuali. 
 
Un'interfaccia TAP (Terminal Access Point) è una rete virtuale a livello Ethernet (livello 2 
OSI). Simula una scheda di rete e viene spesso utilizzata per fornire connettività di rete 
a macchine virtuali, quando collegata a un bridge. 
 
Per configurarle dirigersi su: 

●​ System → Info-OS registry 
In questa pagina, è poi necessario procedere come segue: 

1.​ Aprire la tendina del campo: Loader - System bootstrap configuration information 
2.​ Cliccare "Add new key" per tre volte – aggiungendo quindi tre righe 
3.​ Compilare i campi delle chiavi come segue: 

a.​ Prima chiave: 
i.​ Description: Bridge load 
ii.​ Info-OS Key: if_bridge_load 
iii.​ Value: YES 

b.​ Seconda chiave: 
i.​ Description: TAP load 
ii.​ Info-OS Key: if_tap_load 
iii.​ Value: YES 

c.​ Terza chiave:  
i.​ Description: vboxdrv load 
ii.​ Info-OS Key: vboxdrv_load 
iii.​ Value: YES 

4.​ Premere la spunta verde  sulla destra per confermare le chiavi ed abilitarle col 
bottone "Enable/Disable"  

5.​ Poi salvare con "Save" 
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Dopo aver impostato le chiavi inerenti al Loader, spostarsi sul campo sottostante: 

6.​ Aprire la tenda del campo: Rc - System configuration information 
7.​ Cliccare nuovamente “Add new key” e aggiungere tre chiavi. 
8.​ Compilare i campi delle chiavi come segue: 

a.​ Prima chiave: 
i.​ Description: cloned interfaces 
ii.​ Info-OS Key: cloned_interfaces 
iii.​ Value: bridge0 <tap aggiuntive>​

Esempio con due tap: bridge0 tap0 tap1​
N.B.: ogni interfaccia tap può essere collegata ad una sola VM per 
volta. Se più macchine virtuali devono utilizzare la rete tramite 
bridge, è necessario creare una tap distinta per ciascuna di esse. 

b.​ Seconda chiave: 
i.​ Description: bridge and tap up 
ii.​ Info-OS Key: ifconfig_bridge0 
iii.​ Value: addm <scheda di rete fisica> addm <tap> up​

Esempio con due tap: addm ixl0 addm tap0 addm tap1 up 
c.​ Terza chiave:  

i.​ Description: vboxnet enable 
ii.​ Info-OS Key: vboxnet_enable 
iii.​ Value: YES 

9.​ Premere la spunta verde  sulla destra per confermare le chiavi ed abilitarle col 
bottone "Enable/Disable"  

10.​Poi salvare con "Save" e Riavviare INFO-OS per applicare tutte le modifiche. 
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Dopo il riavvio si potrà assegnare ad una virtual machine una o più delle schede TAP 
create, vedi Utilizzare una scheda di rete alternativa per la vm. A differenza di interfacce 
di rete fisiche o VLAN però, non è necessario attivare le TAP dalla pagina LAN Ethernet. 
 
N.B.: non assegnare alla virtual machine il Bridge, ma solo la/le TAP. 
 

 
 
Se si vuole poter utilizzare più TAP su schede di rete fisiche differenti, sarà necessario 
creare un secondo (o più) Bridge che poggiano sulle altre schede di rete che si desidera 
usare. 
 
Per farlo, sarà necessario modificare e aggiungere righe nel campo: ​
Rc - System configuration information: 

1.​ Nella chiave già creata: “cloned interfaces” → nel campo “Value” → aggiungere il 
secondo (o più) Bridge e le relative TAP aggiuntive a lui associate con la 
seguente formattazione: 

a.​ bridge0 <tap> bridge1 <tap> bridge2 <tap> [...]​
(aggiungere tutte le interfacce bridge e tap necessarie) 

b.​ Esempio con due Bridge: bridge0 tap0 tap1 bridge1 tap2 tap3 
2.​ Creare poi una nuova chiave (oltre quella già creata per il primo Bridge [bridge0]) 

per ogni Bridge aggiuntivo: 
a.​ Description: bridge<numero del Bridge> and tap up​

Esempio: bridge1 and tap up 
b.​ Info-OS Key: ifconfig_bridge<numero del Bridge> 

Esempio: ifconfig_bridge1 
c.​ Value: addm <scheda di rete fisica da associare> addm <tap> up​

Esempio con due tap: addm ixl1 addm tap1 addm tap2 up 
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Esempio con tre Bridge (bridge0, bridge1, bridge2)  

 
 
N.B.: Le TAP ed i bridge creati saranno visibili anche nella pagina: 

●​ Network → Interfaces​
 

Tuttavia, il loro utilizzo è inteso solo e specificatamente per l’uso di virtual machine. 
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Lentezza scheda di rete 
In alcune configurazioni hardware e in combinazione con alcuni sistemi operativi Guest, 
è possibile riscontrare una performance anomala nella velocità e stabilità della scheda 
di rete quando questa è impostata in modalità “Bridged Adapter”. 
Per esempio questo può avvenire con alcune versioni di Windows Server 2022 appaiate 
ad alcune schede di rete Intel da 1 GbE. 
 
Per risolvere, si può modificare la scheda di rete modificandone il tipo come segue: 

●​ Details → Networks→  Network Interface: 1  
○​ Impostare La voce “Adapter Type” su “Paravirtualized Network (virtio-net)”. 

 
Tuttavia, prima di eseguire questa operazione, è necessario pre-installare i driver di tale 
tipo di scheda di rete all’interno del Guest, scaricabili tramite il seguente link: 
https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/archive-virtio/virtio-wi
n-0.1.229-1/ 
Per versioni legacy di Windows invece installare: 
https://fedorapeople.org/groups/virt/virtio-win/direct-downloads/archive-virtio/virtio-wi
n-0.1.189-1/ 
 
Se la connessione di rete dovesse essere troppo lenta per riuscire a scaricare i driver, si 
potrà momentaneamente reimpostare la scheda di rete in modalità “NAT” anziché 
“Bridged Adapter” per procedere all’installazione dei driver e in seguito tornare in 
modalità “Bridged Adapter” e selezionare il tipo di scheda virtuale come sopraindicato. 
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Promiscuous Mode 
La modalità Bridged Adapter dispone di diverse modalità di gestione dei pacchetti 
tramite l’opzione: “Promiscuous Mode”.  
 
Normalmente la scheda di rete riceve solo i pacchetti di rete che hanno il MAC Address 
nell'indirizzo di destinazione. I pacchetti destinati a MAC address differenti non vengono 
esposti alla scheda di rete virtuale. 
 
La modalità promiscua permette al NIC fisico di avere più indirizzi MAC, consentendo a 
tutto il traffico in arrivo di raggiungere ogni MAC address senza essere prima 
selezionato. In alcune infrastrutture di rete e/o con alcuni software potrebbe tornar utile 
sperimentare con questa opzione per vedere se vi sono cambiamenti alla 
velocità/affidabilità della connessione di rete virtuale. 
 
Esistono tre opzioni da poter assegnare alla voce Promiscuous mode: 

1.​ Deny: Tutto il traffico non destinato al MAC Address della scheda di rete virtuale 
viene nascosto alla vm. Questa è l’impostazione predefinita 

2.​ Allow VMs: Questa opzione, come Deny, nasconde i pacchetti esterni da quelli 
dell’host INFO-OS dalle vm se non indirizzati a loro in base al MAC Address ma, 
permette alle vm dello stesso host INFO-OS di vedere il traffico dell’una e 
dell’altra anche se il MAC Address non corrisponde. 

3.​ Allow All: In questa opzione le vm vedranno tutti i pacchetti della rete anche 
quelli non indirizzati a loro sulla base del MAC Address e sarà poi il sistema 
operativo Guest, come in un sistema fisico, a gestirli. 

 

Ulteriori problemi di rete (Software Gestionali) 
Nel caso si riscontrino ulteriori problemi di stabilità di rete, più spesso collegati all’uso 
di particolari software gestionali, vedere la configurazione delle Opzioni aggiuntive delle 
schede di rete fisiche utilizzate dalle vm guest e/o far uso delle TAP. 
 
Seguire la guida in base alla propria revisione di INFO-OS installata e assicurarsi di 
intervenire e modificare i parametri dell’interfaccia a cui è assegnata la scheda di rete 
usata dalla vm che presenta i problemi.  
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Gestione orologio, impostazioni per il Timekeeping 
Il Timekeeping gestisce la coincidenza dell’orologio della virtual machine con quello 
dell’host/reale e in alcune configurazioni può risultare complicato da controllare.  
 
Per esempio, se gli interrupt del timer sono virtualizzati, il gestore degli interrupt in una 
particolare macchina virtuale può essere ritardato quando la macchina fisica è 
occupata, ad esempio con altre macchine virtuali, e la volta successiva, quando l'host 
fisico è inattivo, diversi IRQ potrebbero essere gestiti in blocco per recuperare il tempo 
corrente. 
 
I sistemi operativi sono già progettati tenendo conto di questo aspetto e in genere 
eseguono software per correggere questa deriva, come NTP o w32time. 
 
Di fatto, le prestazioni della sincronizzazione temporale in una macchina virtuale 
dipendono: 

●​ dal tipo e dalla versione del sistema operativo in esecuzione nella macchina 
virtuale 

●​ dal tipo e dalla versione del software dell'hypervisor in esecuzione sulla 
macchina fisica, e quindi dalla programmazione dei tick del timer per le 
macchine virtuali 

●​ e dalle risorse disponibili al sistema e macchine virtuali. 
 
VirtualBox, come altri hypervisor, fornisce meccanismi propri per disciplinare l'ora in 
modo più o meno accurato tramite l'utilizzo dei propri Tools (GuestAdditions), ma in 
alcuni casi è suggerito installare software come il demone NTP nelle macchine virtuali. 
 
Non esiste quindi una configurazione predefinita che funzioni in tutti i casi e situazioni, 
se si dovesse riscontrare un “time drift” (differenza tra orologio/passaggio del tempo 
virtuale e reale) tale da avere un impatto negativo sui servizi/applicativi della virtual 
machine, sarà necessario provare le diverse configurazioni, tra autogestione con NTP e 
impostazioni della virtual machine su VirtualBox allo scopo di risolvere. 
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Di seguito le impostazioni che hanno impatto sul Timekeeping: 
●​ Details  → General info → Advanced Options → Acceleration → 

Paravirtualization Interface →  
○​ Impostare su None 

●​ Details  → General info → Advanced Options →  Motherboard → 
○​ UTC Time 
○​ Host Time Sync 
○​ High Precision Event Timer (HPET) 
○​ Chipset 

 
N.B.: alcune di queste impostazioni, più in particolare le seguenti, possono essere 
dannose al funzionamento della VM e possono ridurre le prestazioni: 
High Precision Event Timer (HPET), Paravirtualization Interface, Chipset. 
 
Consigliamo, come sempre, di assicurarsi di disporre di Snapshot ed eventuali backup 
prima di effettuare prove di questo tipo su macchine in produzione. 
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Creazione e gestione di Snapshot di virtual machine 
Anziché essere gestiti dalla pagina del Folder, gli snapshot di virtual machine create 
vengono gestiti direttamente dalla pagina: 

●​ Virtualization → Machine▼ → [VM interessata] → Snapshot 
 

 
 
Qui si aprirà una finestra che darà visuale sugli snapshot presenti per eventualmente 
replicarli o effettuare il ripristino e consentirà di creare snapshot sia manuali che 
schedulati. 
 
Vedi: Creazione di Snapshot e schedulazioni per dettagli sul funzionamento e 
configurazione di snapshot. 
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Cloni di una Virtual Machine 
Come per Folder e Virtual Disk regolari, è possibile creare Cloni da Snapshot di virtual 
machine e questi saranno utilizzabili e automaticamente caricati nell'inventario di 
virtualizzazione sotto forma di virtual machine. 
 
Quando si crea un Clone di uno Snapshot, viene creata una copia "solo lettura" del file 
system al momento dello snapshot. Il Clone viene quindi montato in un percorso 
separato e può essere utilizzato per scopi di sviluppo, test, analisi forense o salvataggio 
di dati, senza influire sui dati originali della virtual machine. 
 
Come per altri Dataset, poiché lo Snapshot d’origine e il Clone condividono lo stesso 
blocco di dati, il Clone non occupa spazio aggiuntivo fino a quando non viene apportata 
una modifica. In tal caso, INFO-OS creerà una copia differenziale dei dati modificati, che 
viene memorizzata in modo incrementale e solo in corrispondenza delle differenze. 
 
Per creare un Clone di una virtual machine andare in: 

●​ Virtualization → Machine▼ → [VM interessata] → Clone 
Si aprirà una finestra di dialogo nella quale si dovrà selezionare lo Snapshot che si 
intende clonare tramite l’apposita tendina ‘Select snapshot’ e sarà anche possibile 
selezionare “Take a snapshot of the current state” così da generare uno Snapshot da 
clonare sul momento.  
Infine si definirà il nome della nuova virtual machine clonata e si potrà quindi procedere 
cliccando “Clone” così da generare la virtual machine Clone.  
 

 
 
N.B.: Prima di avviare la virtual machine Clone è necessario modificare la porta di 
connessione al desktop virtuale assegnando una non utilizzata, poiché la virtual machine 
originale ed il Clone appena generato hanno la medesima porta. 
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N.B.2: La virtual machine Clone generata avrà i mac address delle schede di rete virtuali 
automaticamente rigenerati così da essere diversi dall’originale per evitare conflitti di rete. 
Si ricorda tuttavia che il sistema operativo potrebbe generare altri tipi di conflitti di rete per 
via di possibili IP, nome computer, hostname e netBios name identici all’originale. 
 
Una volta creato il Clone si può verificare lo Snapshot di origine tramite: 

●​ Data → Folders - Virtual disks → [POOL] → VBox → [VM Clone] → Clone Origin: 
Notare che il Folder Clone della VM Clone ha un'icona differente dalle VM non Clone. 
 
N.B.3: Terminata la sua funzione il Clone deve essere cancellato! Poiché il Folder(VM) e lo 
Snapshot originali non possono essere cancellati finché il Clone stesso esiste.  
Per questi motivi i Cloni non devono essere usati a lungo termine né messi in produzione. 
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Repliche di Virtual Machine 
A differenza di Dataset (Folder e Virtual Disk) ‘classici’ le virtual machine dispongono di 
alcune possibilità in più per quanto riguarda la creazione di repliche di snapshot, sia 
singoli che schedulati, sia remoti che locali. 
 
Esiste infatti la possibilità di replicare la virtual machine in due modi: 

1.​ Replicate this snapshot as a folder 
2.​ Replicate this snapshot as a virtual machine 

 
Nel primo caso quando verrà effettuata una replica verrà creata una copia del Folder 
della virtual machine al dato momento definito dallo snapshot, così come avviene nel 
‘normale’ e ‘tradizionale’ sistema di replicazione. 
 
Nel secondo caso invece, verrà copiata e direttamente importata nell’inventario di 
virtualizzazione, la virtual machine in questione così come si presentava al dato 
momento definito dallo snapshot. 
 
In questo secondo caso alla replica della virtual machine verrà automaticamente 
cambiato l’UUID per permettere al sistema di virtualizzazione, in caso di replica locale, 
di non entrare in conflitto per la presenza di due virtual machine con UUID identico. 
 
N.B.: Per poter eseguire la replica remota in modalità virtual machine anziché Folder, è 
necessario che il sistema primario e secondario abbiano il POOL col medesimo nome e 
che il sistema secondario, come il primario, disponga di licenza per la virtualizzazione ed 
abbia tale servizio attivo! 
 
Vedi la prima sezione di Repliche remote (singole e schedulate) per la configurazione 
delle chiavi di replica tra due sistemi INFO-OS per consentire le repliche remote 
(backup). 
 
Come per altri tipologia di replica, è possibile vederne l’avanzamento tramite: 

●​ Data → Replication status: 
Vedi: Status Replicazione 
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Replica singola Virtual Machine 
Effettuando una replica singola della virtual machine si creerà una copia dei dati della 
stessa al momento definito dallo Snapshot scelto. 
 
Per effettuare una replica singola andare in: 

●​ Virtualization → Machine▼ → [VM interessata] → Snapshot → [Snapshot 
interessato] 

 
Qui si avranno due opzioni (come sopra descritto): 

●​ Replicate this snapshot as a folder ​
Per replicare lo snapshot in modalità ‘tradizionale’ come Folder:​
 

○​ Selezionare “Local” e indicare destinazione all’interno del POOL e il nome 
del nuovo Folder per eseguire una replica locale.​
 

○​ Selezionare “Remote” e compilare i campi di IP, destinazione all’interno del 
POOL e il nome del nuovo Folder per eseguire una replica remota.​
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●​ Replicate this snapshot as a virtual machine ​
Per replicare lo snapshot come virtual machine:​
 

○​ Selezionare “Local” e indicare destinazione all’interno del POOL e il nome 
del nuovo Folder per eseguire una replica locale.​
 

○​ Selezionare “Remote” e compilare i campi di IP, destinazione all’interno del 
POOL e il nome del nuovo Folder per eseguire una replica remota.​
 
N.B.: Per poter eseguire la replica remota in modalità virtual machine è 
necessario che il sistema primario e secondario abbiano il POOL col 
medesimo nome e che il sistema secondario, come il primario, disponga di 
licenza per la virtualizzazione ed abbia tale servizio attivo! 
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Replica schedulata Virtual Machine 
Impostando una schedulazione di snapshot replicati, si creerà un backup dei dati della 
virtual machine costantemente aggiornati all’ultimo snapshot eseguito, è anche 
possibile richiedere al sistema di tenere più snapshot replicati di quanti se ne tenga in 
locale nel Dataset principale (voce “Keep last”).  
Questo consente di liberare più spazio nella macchina principale pur mantenendo la 
possibilità di visionare snapshot più vecchi poiché contenuti nel sistema secondario di 
backup. 
 
Per creare una replica schedulata andare in: 

●​ Virtualization → Machine▼ → [VM interessata] → Snapshot → Schedule 
snapshots  → Add a new schedule 
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Qui si avranno due opzioni (come sopra descritto): 
●​ Replicate as VM​

Per creare una schedulazione di replicazione come virtual machine: 
​
Si dovrà indicare l’IP della macchina receiver (secondaria) che riceverà la replica 
schedulata. In automatico la copia (replica) della virtual machine verrà creata 
dentro a [POOL]\VBox e verrà importata dal sistema rendendola utilizzabile nel 
sistema secondario.​
​
N.B.: Per poter eseguire la replica remota in modalità virtual machine è necessario 
che il sistema primario e secondario abbiano il POOL col medesimo nome e che il 
sistema secondario, come il primario, disponga di licenza per la virtualizzazione 
ed abbia tale servizio attivo!​
 
N.B.2: Fintanto che la schedulazione è attiva, eventuali modifiche effettuate nel 
sistema receiver (secondario) verranno sovrascritte dalla ricezione di snapshot più 
aggiornati dal sistema sender primario.​
​
N.B.3: Non è possibile creare una replicazione schedulata in modalità VM in locale, 
questo perché equivarrebbe a disporre di una copia locale inutilizzabile poiché in 
costante aggiornamento e richiederebbe risorse di sistema per effettuare l’import 
della virtual machine che necessita anche di modifica di UUID per non generare 
conflitti.​
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●​ Replicate as folder​
Per creare una schedulazione di replicazione in modalità ‘tradizionale’ come 
Folder:​
​
Come per la creazione di una replicazione di un Dataset ‘classico’, se si configura 
una replica remota, si dovrà indicare l’IP della macchina remota e la destinazione 
in cui verrà creata la cartella con nome assegnato “name” della replica dello 
Snapshot. ​
​
In questo caso è anche possibile eseguire una replica locale schedulata come 
Folder poiché non è necessario impiegare risorse di sistema per l'importazione e 
modifica UUID della virtual machine. 

 

 
 
In entrambe le configurazioni, sia in modalità VM che Folder, si potrà impostare la voce 
HSR su Auto o Manual, questa gestisce il comportamento in caso di non 
corrispondenza tra gli snapshot originali e quelli replicati, vedi l’ultima configurazione di: 
Creazione di una schedulazione remota per dettagli sul comportamento di questa 
funzione.  
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Per abilitare la replica in una schedulazione di Snapshot già esistente è sufficiente 
modificare la stessa tramite:  

●​ Virtualization → Machine▼ → [VM interessata] → Snapshot → Schedule 

snapshots  → [Schedulazione snapshot interessata] ​
 

●​ Data → Scheduled Snapshots → [Dataset interessato] → [Schedulazione 

snapshot interessata]  
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A partire da vers. 4.5.0.0 - rev. 31 di INFO-OS è possibile schedulare una replica primaria 
e secondaria, permettendo quindi di replicare la stessa VM due volte con il medesimo 
Snapshot. 
 
Durante la modifica o creazione di una schedulazione di uno Snapshot si potrà quindi 
vedere e gestire l’opzione di una “Main Replica” ed una “Secondary Replica”.  
 
Queste potranno essere inviate sul medesimo sistema, su di uno differente o anche in 
locale indipendentemente l’una dall’altra e potranno essere una o entrambe in modalità 
Folder o VM. 
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Registrazione di una Virtual Machine 
È possibile registrare virtual machine collocate all’interno del Folder di virtualizzazione 
“VBox” del POOL, a partire da: 

●​ Vers. 4.5.0.0 Rev. 0039 
●​ Vers. 5141 Rev. 1015 

 
Per importare una virtual machine: 

1.​ Andare nella pagina: 
a.​ Virtualization → Machine▼ → Register vm 

2.​ Navigare all’interno del Folder della vm dentro al sotto-Folder “VBox” 
3.​ Selezionare il file .vbox della vm 
4.​ E cliccare “Register” 
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Unregister di Virtual Machine 
A partire dalle versioni sopra indicate è stata aggiunta la possibilità di rimuovere le vm 
dalla lista di vm registrate (senza rimuoverne i dati/contenuti). 
 
Per farlo, selezionare la vm interessata e cliccare: “Unregister”. 
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Import di una Virtual Machine esterna 
Nel caso di import da altro hypervisor è possibile importare sia file di virtual machine 
complete, in .ova o .ovf che importare un disco virtuale per assegnarlo ad una virtual 
machine presente su INFO-OS. 
INFO-OS è in grado di utilizzare le seguenti versioni di dischi virtuali:  

●​ VDI (Virtual Disk Image - nativa) 
●​ VHD (Virtual Hard Disk) 
●​ VMDK (Virtual Machine Disk) 
●​ HDD (Parallels Hard Disk) 
●​ QCOW (QEMU Copy-On-Write) 
●​ QED (QEMU enhanced Disk) 

Import di Virtual Machine completa 
Per importare una virtual machine in .ova o .ovf dirigersi su:  

●​ Virtualization → Machine▼ → Import appliance 

 
 
E seguire le indicazioni a video selezionando il file della virtual machine che si vuole 
importare dall’interno del POOL. 
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 Una volta iniziata l’importazione si potrà monitorare il suo avanzamento 
dall’apposito bottone in alto a destra dei processi in corso.  
 
Quando l’importazione sarà terminata, sarà necessario verificare e/o abilitare la 
Connessione al Desktop virtuale prestando attenzione che non esista già una virtual 
machine che utilizza la medesima porta per la connessione. 

140 



Import di una Virtual Machine ESXi 
Di seguito la procedura per l’importo di una Virtual Machine di vmware ESXi: 

1.​ Esportiamo la VM di ESXi in formato .ovf.​
 

2.​ Importiamo la VM dopo averla inserita nel POOL (Repository).​
N.B.: È previsto che la VM appena importata non risulti funzionante.​
N.B.: In base alla versione di vmware dalla quale si è esportato la VM, è possibile 
che risulti funzionante e che i successivi step non siano necessari.​
 

3.​ Copiamo i dischi della Virtual Machine importata cambiandone il formato da 
.vmdk a .vhd (VHD) tramite: 

○​ Virtualization → Machine▼ → [VM in questione] → Details → Storage → 
Edit → Edit this disk  → Copy 

○​ Virtualization → Media Manager▼ → List hdds → [Disco in questione] → 
Edit this disk  → Copy 

 
4.​ Infine creiamo una nuova Virtual Machine con caratteristiche uguali a quella 

importata da ESXi e le associamo il disco appena copiato selezionando: “Use an 
existing virtual hard disk” durante la fase di creazione oppure, nel caso si 
disponga di più dischi, tramite: 

○​ Virtualization → Machine▼ → [VM in questione] → Details → Storage → 
Edit → Add disk 

N.B.: Per un corretto funzionamento i dischi vanno inseriti nella Controller SATA. 
 

Una volta completate le operazioni si potrà avviare ed utilizzare la nuova Virtual 
Machine, eventualmente eliminando quella importata non funzionante.  
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Import di un disco virtuale 
Per importare un disco vi sono due opzioni entrambe svolte tramite: 

●​ Virtualization → Media Manager▼ → Import from file 

 
 
Qui sarà possibile sia importare un disco, selezionandolo dal POOL, all’interno della lista 
dei dischi sia importarlo e consegnarlo direttamente ad una virtual machine esistente 
selezionandola dalla tendina.  
 
N.B.: Durante la fase di Import è necessario attendere fino al completamento del 
processo. 
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Il disco importato sarà poi visibile da: 
●​ Virtualization → Media Manager▼ → List hdds 

 

 
 
Se il disco viene importato all’interno della lista dei dischi senza specificare una virtual 
machine alla quale assegnarlo, sarà possibile aggiungerlo ad una virtual machine 
tramite le impostazioni della stessa, come segue: 

●​ Virtualization → Machine▼ → [VM in questione] → Details → Storage → Edit 
○​ Qui selezionare il tipo di controller che si vuole utilizzare, di default SATA e 

specificare il disco da assegnare: 
■​  Add disk → Use an existing virtual hard disk → Select disk▼ 

Import di una macchina fisica 
Su di INFO-OS è poi anche possibile importare macchine fisiche trasformandole in 
virtuali. 
Per esempio per importare una macchina Windows, si potrà scaricare l’utility ufficiale di 
Microsoft per la conversione del disco fisico in un disco virtuale, di seguito il  
link al download: 
https://learn.microsoft.com/it-it/sysinternals/downloads/disk2vhd 
 
Dopodiché nella configurazione della creazione del disco virtuale, come spiegato nella 
pagina web dell’utility, si potrà direttamente utilizzare la cartella precedentemente 
creata in Setup iniziale, Repository, come punto di arrivo del file (.VHD). 
 
Ottenuto il caricamento del file del disco basterà creare una virtual machine con 
caratteristiche simili alla macchina fisica dalla quale origina e collegare il file disco alla 
stessa importandolo come sopra indicato in Import di un disco virtuale.  
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Esportazione di una Virtual Machine 
Per eseguire l’esportazione di una virtual machine andare in: 

●​ Virtualization → Machine▼ → Export appliance 

 
 
Qui si presenterà una finestra che richiede quale virtual machine esportare, in quale 
Folder esportarla (generalmente in Repository, vedi: Setup iniziale), con quale nome e in 
quale formato. 
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 Una volta iniziato l’Export si potrà monitorare il suo avanzamento dall’apposito 
bottone in alto a destra dei processi in corso.  
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Una volta terminata l’esportazione sarà necessario modificare i permessi del Folder di 
esportazione per assegnare al file il permesso di modifica da parte di utenti esterni ad 
INFO-OS. 
​
Per far ciò entrare in: 

●​ Data → Folders - Virtual disks → [Folder contenente la virtual machine esportata] 

→ Access control → Edit this permissions  
 
Poi abilitare l’opzione “Recursive:” impostandola su “YES” e modificare i permessi come 
necessario e poi salvare le modifiche. 
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Virtualizzare con ESXi in convergenza 
Nei sistemi INFO-OS convergenti viene utilizzato ESXi come Host e virtualizzato 
INFO-OS nel medesimo volume. Effettuando poi il pass-through della controller dei 
dischi, INFO-OS gestirà il pool dati. 
​
INFO-OS condividerà quindi Volumi e Folder verso ESXi, generalmente tramite protocollo 
NFS, per ospitare le Virtual Machines, e verso i Client come storage dati. 

Configurazione virtual network standard per interazione tra 
INFO-OS e ESXi 
Innanzitutto, su ESXi dall’apposita pagina Networking viene creato un virtual switch che 
verrà utilizzato per isolare il traffico della condivisione dei volumi fra INFO-OS e ESXi. 
 
Dal momento che INFO-OS è virtualizzato all’interno di ESXi, non è necessario associare 
né collegare una porta di rete al virtual switch, poiché la comunicazione è interna, 
sostenuta dal virtual switch stesso. 
È tuttavia possibile associare al virtual switch una scheda di rete fisica nel caso si 
voglia dividere il traffico di rete di INFO-OS o altre virtual machine, per esempio per 
l’esecuzione di repliche a un sistema secondario.  
N.B.: Così facendo si dovranno verificare tutti gli IP assegnati per evitare conflitti nel caso 
si disponga di più sistemi Converged vmware nella medesima rete. 
 
Di seguito la creazione di “vSwitch Volumes” alla quale rimuoviamo la scheda di rete 
(Uplink) che viene in automatico assegnata: 
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Successivamente si procede alla creazione di due port group all’interno del nuovo 
virtual switch, atti ad ospitare rispettivamente un VMkernel ESXi (Management 
Network1) e una porta di rete virtuale di INFO-OS (Volumes): 
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A questo punto si crea un VMkernel ESXi abilitato al “Management” all’interno del 
relativo port group, assegnandogli un IP statico su classe di rete non utilizzata. Questo 
viene fatto allo scopo di evitare conflitti nel caso venga assegnata successivamente 
una porta di rete al virtual switch “vSwitch Volumes” e che venga collegata alla rete. 
 
N.B.: Come già spiegato, quando è assegnata al virtual switch una scheda di rete fisica, è 
SEMPRE bene verificare che tale IP e classe di rete non siano già utilizzati all’interno della 
rete nella quale il sistema verrà inserito ANCHE se la porta fisica non è collegata per 
evitare alcun tipo di conflitti. 
 

  
 
Successivamente, tramite la configurazione della Virtual Machine INFO-OS, si assegna 
una scheda di rete virtuale al relativo port group Volumes: 
 
N.B.: È bene identificare la scheda di rete in base al MAC Address, poiché l’ordine mostrato 
da ESXi non coincide con l’ordine visibile da INFO-OS. 
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Si andrà quindi ad aggiungere un’interfaccia di rete, denominata OPT1, su INFO-OS: 

●​ Network → Interfaces → LAN Ethernet → Add + 
○​ Come indicato al punto precedente, verificare che il MAC Address coincida 

con la scheda assegnata al port group Volumes. 

 

150 



Ad essa dovrà essere assegnato un IP statico, nella medesima classe di rete del 
VMkernel di ESXi, tramite: 

●​ Network → Interfaces → LAN Ethernet → [porta interessata (OPT1)] → Edit  
○​ L’IP assegnato dovrà essere diverso da eventuali altri IP su tale classe di 

rete (nel caso ad esempio siano presenti altri sistemi convergenti simili 
nella rete). 

○​ In “Advanced Settings”, impostare la voce “Duplex” su “full-duplex” 

 
 
Una volta terminate le configurazioni, tramite ESXi, si potrà verificare la corretta 
impostazione del virtual network, MAC Address, IP, port group e porte di rete usando 
l’apposita pagina di configurazione del virtual switch “vSwitch Volumes”. 
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Condivisione Folder per la creazione di Virtual Machine ESXi 
Per la creazione di Virtual Machine è necessario condividere un Folder da INFO-OS 
verso ESXi tramite protocollo NFS e eseguire il mount del datastore NFS su ESXi.  
 
A tal proposito, fare riferimento a Creazione e gestione di un Dataset (Folder e Virtual 
Disks) e Condivisione di un Folder in NFS assicurandosi, nei parametri di condivisione 
NFS, di: 

1.​ impostare come IP o classe di IP, la medesima che è stata dedicata alla 
condivisione dei volumi (virtual switch “Switch Volumes”) o del VMkernel 
presente in tale virtual switch. 

2.​ impostare la voce “All users as root:” su “Yes” 
 
È buona pratica utilizzare, per il Folder su INFO-OS e il datastore su ESXi, un nome che 
identifichi chiaramente la Virtual Machine che esso andrà ad ospitare. Nel nostro 
esempio, impostiamo come nome “ds_ws22”, dove “ds” corrisponde a “datastore” e 
“ws22” al nome della Virtual Machine. 
 
N.B.: Allo scopo di avere flessibilità nella gestione di snapshot e controllo sullo spazio 
occupato dalle Virtual Machine, non è consigliato creare all’interno del medesimo 
Folder/datastore NFS più di una Virtual Machine! Ogni Virtual Machine dovrebbe avere un 
proprio Folder su INFO-OS! 
 
N.B.2: Come per la creazione di Folder generici (condivisi via SMB o altri protocolli per uso 
storage), è sconsigliata la nidificazione di Folder (creazione di Folder dentro a Folder nel 
pool di INFO-OS). 
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Ora che il Folder è stato creato e condiviso, si può procedere al montaggio del datastore 
NFS su ESXi aggiungendolo come nuovo datastore NFS. 
 
Una volta collegato con successo il nuovo datastore, si può procedere alla creazione 
della Virtual Machine al suo interno. 
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Cancellazione di una Virtual Machine 
Se si desidera, per qualsivoglia motivo, cancellare una Virtual Machine, il relativo 
datastore NFS e il corrispondente Folder su INFO-OS, la procedura corretta è la 
seguente: 

1.​ Cancellare o rimuovere dall’inventario la VM in questione. 
2.​ Cancellare il datastore NFS su ESXi 
3.​ Cancellare la condivisione NFS e eventuali snapshot del Folder corrispondente su 

INFO-OS 
4.​ In ultimo cancellare il Folder su INFO-OS 

 
In questo modo tutto ciò che compone la VM e i vari datastore verranno definitivamente 
cancellati senza lasciare tracce o processi in sospeso. 
 
N.B.: se si dovesse come primo step cancellare il Folder lato INFO-OS, ESXi continuerebbe 
a far richiesta del datastore NFS non più presente, generando un loop di richieste visibile 
nel log di INFO-OS. Questa situazione sarà risolvibile solo ricreando il Folder in questione 
col medesimo nome, condividendolo nuovamente via NFS, e poi eseguendo in ordine 
corretto la procedura sopra indicata. 

Avvio e spegnimento di un sistema Converged INFO-OS e ESXi 
Dato il funzionamento di un sistema Converged, è necessario per quanto riguarda 
l’avvio, spegnimento e riavvio del sistema seguire una specifica procedura: 

●​ Nei sistemi convergenti viene abilitato l’avvio automatico (autostart) della Virtual 
Machine di INFO-OS, in modo da consentire la condivisione dei volumi nei quali 
risiedono le altre Virtual Machine. 

○​ Per questo motivo, nel caso venga abilitato l’avvio automatico di altre 
Virtual Machine, sarà fondamentale mantenere INFO-OS come primo e 
impostare un opportuno ritardo per l’avvio delle successive. 

○​ Nel caso le Virtual Machine vengano avviate manualmente invece, sarà 
sufficiente attendere l’avvio di INFO-OS con conseguente condivisione dei 
volumi verso ESXi. 

 
●​ La corretta procedura di spegnimento o riavvio di questi sistemi segue lo stesso 

principio di funzionamento. 
○​ La prima cosa da fare sarà quindi spegnere tutte le Virtual Machine 

eccetto INFO-OS. 
○​ Una volta spente tutte, si potrà procedere allo spegnimento di INFO-OS. 
○​ Infine si potrà eseguire lo spegnimento o il riavvio dell’Host ESXi.  
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Virtualizzazione con Proxmox in convergenza 
Nei sistemi INFO-OS convergenti in cui viene utilizzato Proxmox come Host, INFO-OS 
viene virtualizzato al suo interno nel medesimo volume. Effettuando poi il pass-through 
della controller dei dischi, INFO-OS gestirà il pool dati. 
​
INFO-OS condividerà quindi Volumi e Folder verso Proxmox, generalmente tramite 
protocollo NFS, per ospitare le Virtual Machine, e verso i Client come storage dati. 

Configurazione network per l’interazione Proxmox e INFO-OS 
Su proxmox dall’apposita pagina Network del host pve viene creato un Linux Bridge che 
verrà utilizzato per isolare il traffico della condivisione dei volumi fra INFO-OS e 
Proxmox.  
 
Dal momento che INFO-OS è virtualizzato all’interno di Proxmox, non è necessario 
associare né collegare una porta di rete al Bridge, poiché la comunicazione è interna, 
sostenuta dal Bridge stesso. 
 
Di seguito la creazione del Linux Bridge alla quale assegnamo una classe di IP 
inutilizzata: 
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Successivamente, tramite la configurazione della Virtual Machine INFO-OS, si assegna 
una scheda di rete virtuale che poggia sul nuovo Bridge. 
 
N.B.: È bene identificare la scheda di rete in base al MAC Address, poiché l’ordine mostrato 
da Proxmox potrebbe non coincidere con l’ordine visibile da INFO-OS. 
 

 
 
Si andrà quindi ad aggiungere un’interfaccia di rete, denominata OPT1, su INFO-OS: 

●​ Network → Interfaces → LAN Ethernet → Add + 
○​ Come indicato al punto precedente, verificare che il MAC Address coincida 

con la scheda assegnata al Linux Bridge preposto. 
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Ad essa dovrà essere assegnato un IP statico, nella medesima classe di rete che si ha 
assegnato a Proxmox nella creazione del Linux Bridge, tramite: 

●​ Network → Interfaces → LAN Ethernet → [porta interessata (OPT1)] → Edit  
○​ L’IP assegnato dovrà essere diverso da eventuali altri IP su tale classe di 

rete (nel caso ad esempio siano presenti altri sistemi convergenti simili 
nella rete). 

○​ In “Advanced Settings”, impostare la voce “Duplex” su “full-duplex” 
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Condivisione Folder per la creazione di Virtual Machine Proxmox 
Per la creazione di Virtual Machine è necessario condividere un Folder da INFO-OS 
verso Proxmox tramite protocollo NFS e eseguire il mount del datastore NFS su di esso.  
 
A tal proposito, fare riferimento a Creazione e gestione di un Dataset (Folder e Virtual 
Disks) e Condivisione di un Folder in NFS assicurandosi, nei parametri di condivisione 
NFS, di: 

1.​ impostare come IP o classe di IP, la medesima che è stata dedicata alla 
condivisione dei volumi (Linux Bridge) o dell’IP assegnato a Proxmox in tal 
Bridge. 

2.​ impostare la voce “All users as root:” su “Yes” 
 
È buona pratica utilizzare, per il Folder su INFO-OS e lo Storage su Proxmox, un nome 
che identifichi chiaramente la Virtual Machine che esso andrà ad ospitare. Nel nostro 
esempio, impostiamo come nome “ds_ws22”, dove “ds” corrisponde allo Storage e 
“ws22” al nome della Virtual Machine. 
 
N.B.: Allo scopo di avere flessibilità nella gestione di snapshot e controllo sullo spazio 
occupato dalle Virtual Machine, non è consigliato creare all’interno del medesimo 
Folder/datastore NFS più di una Virtual Machine! Ogni Virtual Machine dovrebbe avere un 
proprio Folder su INFO-OS! 
 
N.B.2: Come per la creazione di Folder generici (condivisi via SMB o altri protocolli per uso 
storage), è sconsigliata la nidificazione di Folder (creazione di Folder dentro a Folder nel 
pool di INFO-OS). 
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Ora che il Folder è stato creato e condiviso, si può procedere al montaggio del datastore 
NFS su Proxmox aggiungendolo come nuovo Storage. 
Una volta collegato con successo il nuovo datastore, si può procedere alla creazione 
della Virtual Machine al suo interno. 
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Cancellazione di una Virtual Machine 
Se si desidera, per qualsivoglia motivo, cancellare una Virtual Machine, il relativo 
Storage NFS e il corrispondente Folder su INFO-OS, la procedura corretta è la seguente: 

1.​ Cancellare o rimuovere dall’inventario la VM in questione. 
2.​ Rimuovere lo Storage NFS su Proxmox 
3.​ Cancellare la condivisione NFS e eventuali snapshot del Folder corrispondente su 

INFO-OS 
4.​ In ultimo cancellare il Folder su INFO-OS 

 
In questo modo tutto ciò che compone la VM e i vari Storage verranno definitivamente 
cancellati senza lasciare tracce o processi in sospeso. 
 
N.B.: se si dovesse come primo step cancellare il Folder lato INFO-OS, Proxmox 
continuerebbe a far richiesta dello Storage NFS non più presente, generando un loop di 
richieste visibile nel log di INFO-OS. Questa situazione sarà risolvibile solo ricreando il 
Folder in questione col medesimo nome, condividendolo nuovamente via NFS, e poi 
eseguendo in ordine corretto la procedura sopra indicata. 

Avvio e spegnimento di un Converged INFO-OS e Proxmox 
Dato il funzionamento di un sistema Converged, è necessario per quanto riguarda 
l’avvio, spegnimento e riavvio del sistema seguire una specifica procedura: 

●​ Nei sistemi convergenti viene abilitato l’avvio automatico (autostart) della Virtual 
Machine di INFO-OS, in modo da consentire la condivisione dei volumi nei quali 
risiedono le altre Virtual Machine. 

○​ Per questo motivo, nel caso venga abilitato l’avvio automatico di altre 
Virtual Machine, sarà fondamentale mantenere INFO-OS come primo e 
impostare un opportuno ritardo per l’avvio delle successive. 

○​ Nel caso le Virtual Machine vengano avviate manualmente invece, sarà 
sufficiente attendere l’avvio di INFO-OS con conseguente condivisione dei 
volumi verso Proxmox. 

 
●​ La corretta procedura di spegnimento o riavvio di questi sistemi segue lo stesso 

principio di funzionamento. 
○​ La prima cosa da fare sarà quindi spegnere tutte le Virtual Machine 

eccetto INFO-OS. 
○​ Una volta spente tutte, si potrà procedere allo spegnimento di INFO-OS. 

Infine si potrà eseguire lo spegnimento o il riavvio dell’Host Proxmox. 
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